[LAU] Qtractor 0.4.8, compile prob with libslv2 on Kubuntu Hardy

Rui Nuno Capela rncbc at rncbc.org
Tue Jan 25 16:36:29 UTC 2011

 On Tue, 25 Jan 2011 16:42:06 +0100, Nigel Henry 
 <cave.dnb2m97pp at aliceadsl.fr> wrote:
>>    ./configure --disable-lv2-gtk-ui
> Hi Rui.
> It compiles ok with the above ./configure option
> My libgtk2.0-dev is version 2.12.9-3ubuntu5. Torben, in his reply to
> the list
> said gtk_widget_get_window was added in 2.14.
> He said you can use widget->window in older gtk versions.
> Is there some file/files I can hack in qtractor's src to change that?

 yes, following torbenh's hint by the letter you may try and edit 
 src/qtractorLv2Plugin.cpp, line 1027,



 but i disclaim any guarantee on that or whether it suffices (no gtk 
 intelligence here, quite the opposite:)

 rncbc aka Rui Nuno Capela
 rncbc at rncbc.org

More information about the Linux-audio-user mailing list