[Jack-Devel] Jack won't start on boot

alex adrcki at gmail.com
Wed Jul 19 23:14:00 CEST 2017

On 07/09/2017 05:34 PM, sqweek wrote:
> On 9 July 2017 at 22:21, alex <adrcki at gmail.com 
> <mailto:adrcki at gmail.com>> wrote:
>     Indeed that seems like a reason. I'm SSHing into to Odroid with -X
>     so I can launch Pd with its GUI, so I tried to SSH without -X and
>     jack wouldn't start, but then SSHing back with -X made jack start.
>     Can you post an example of how I should start jack with a startup
>     mechanism that's run by my graphical environment? I'm not really
>     following there...
> Having the graphical environment start jackd assumes that there is a 
> graphical environment running on the Odroid, which I don't believe is 
> the case here? Using -X with ssh forwards X11 connection attempts on 
> the Odroid to the X server on your local machine, but since dbus afaik 
> isn't network transparent[1] the DISPLAY you end up with via ssh -X 
> will I think not be useful for the dbus side of jack. So you can 
> probably get away with setting DISPLAY to something arbitrary in your 
> init script, like:
> DISPLAY=:0 jackd -dalsa ...
Eventually that did it! At first I replied to this email saying that it 
partially worked since jack was starting but no sound was coming out. 
Eventually the latter happened due to some (probably) bug in Pd which I 
"solved" with a work around.
So now I can safely say that adding "DISPLAY=:0 before calling jackd did 
the trick and now I do get sound on boot.

Thanks everyone for your suggestions!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.linuxaudio.org/archives/jackaudio/attachments/20170720/3f99915e/attachment.html>

More information about the Jackaudio mailing list