[linux-audio-dev] System Exclusive question

chris.wareham at btopenworld.com chris.wareham at btopenworld.com
Tue Jun 10 07:59:00 UTC 2003

Clemens Ladisch <clemens at ladisch.de> wrote:
> chris.wareham at btopenworld.com wrote:
> > Has anyone had succes in getting SysEx data flowing back and forth
> > between Roland sound modules and their computer?
> Yes, SC-8820, over USB.
> > I have attached my
> > simple test program in case I'm doing something obviously wrong.
> I see nothing obviously wrong.
> It might be time-saving to try the low-tech approach first:
> do a "cat /dev/midi42 > somefile", then, on another console, run:
> echo -ne '\xf0\x41\x10\x16\x11\x04\x01\x76\x00\x01\x76\x0e\xf7' > /dev/midi42

I'll try this approach tonight.

> > > > However, whenever I send a Request Data
> > > >message the unit doesn't appear to respond. It definitely receives the
> > > >message as the MIDI activity light comes on. But when I try to read from
> > > >the MIDI device file my call blocks forever.
> My unit's light is active while the dump is being transmitted (several
> seconds, depending on the size of the data). Are you sure your's is
> sending anything?

The MIDI activity light flashes *very* briefly, so it could be that
nothing's being sent back.

> > I have tried using Linux, but gave up when I couldn't get ALSA or
> > OSS to recognise my USB MIDI interface, (a Yamaha UX96). Under
> > NetBSD it's recognised as soon as I plug it in.
> Any somewhat recent version of ALSA does support the UX96.

I tried RedHat 9.0 and the CCRMA stuff, but I guess I mustn't have setup
the modules.conf file properly. I'm used to the monolithic kernel
approach, and I found the whole modules.conf thing confusing. I assume I
need an entry in there to load the USB MIDI interface driver - could you
send me your modules.conf so I can see what sort of entries are


More information about the Linux-audio-dev mailing list