[linux-audio-dev] SBLive again

Josh Green jgreen at users.sourceforge.net
Mon May 19 19:06:01 UTC 2003

On Mon, 2003-05-19 at 06:02, torbenh at gmx.de wrote:
> On Mon, May 19, 2003 at 11:17:14AM +0200, Lukas Degener wrote:
> > Josh Green wrote:
> > 
> > >The symptoms of your problem remind me of what I experienced with full
> > >duplex operation on a SB Live (i.e., recording and playing back at the
> > >same time). Are you using it in full duplex mode? I seem to remember
> > >this having something to do with the record and playback buffers
> > >drifting out of sync. I'm not sure it was ever solved though. It was
> > >quite a while ago when I was playing with this stuff. Cheers.
> > >	Josh Green
> > > 
> > >
> > I will try to disable full duplex and see what happens then.
> > If this actualy is the reason behind it, i will have to buy another 
> > soundcard. :-(
> > Full duplex operation is required for most of the things i would like to do.
> > Maybe i should ask the guys at creative if they know another solution.
> i dont have these problems at home...
> if it sound like clipping it could be clipping in the dsp.
> pcm volume is done on the dsp... master volume in AC97 (analogue)
> also bass/treble settings could show this behaviour...
> did you test the OSS drivers ?

The problem that I mentioned, in regard to full duplex, doesn't relate
to clipping I don't think. From what I experienced I think its a problem
with the record and playback buffers getting out of sync (like say if
you tried to do full duplex with 2 different sound cards). Things would
be perfectly fine, then a few little pops and clicks which would
gradually get worse until an overrun occurs, then back to being okay
again (sometimes I would do something to purposefully cause an overrun,
to get things synchronized again). As far as I can tell this is probably
an ALSA problem, although my tests using OSS were inconclusive (or to
rephrase, I can't remember :) I think the OSS SB Live drivers might be
able to do full duplex, would be interested to test it again to see if
it is indeed an ALSA specific problem. What version of ALSA are you
using Lukas?  Cheers.
	Josh Green

More information about the Linux-audio-dev mailing list