[linux-audio-dev] muse and /dev/rtc

Robert Jonsson rj at spamatica.se
Sun Nov 21 17:06:30 UTC 2004

Hi Werner,

söndagen den 21 november 2004 14.16 skrev Werner Schweer:
> enter as root
>       "echo 1024 > /proc/sys/dev/rtc/max-user-freq"

I had tried that previously, tried it again and it does not work for me 

> this allows users to set rtc frequencies up to 1024 Hz

Right, and since I'm currently trying as root it shouldn't make any 

I get the feeling something is seriously wrong with the RTC. I tried:
cat /dev/rtc

which I recall previously just meant that the cat hanged on the device.

Now if I do this it returns with the error:
cat: /dev/rtc: Input/output error

I got a mail suggesting that it could have something to do with HPET, High 
Precision Event Timers. Don't know if that's included in this kernel, will 


> /werner
> On Saturday 20 November 2004 21:59, Uwe Koloska wrote:
> > Hello,
> >
> > now that my audio inteerface is working, I can try the wealth of audio
> > applications.
> >
> > Starting the SuSE supplied muse (0.7.0) it refuses to start cause it
> > cannot use /dev/rtc.  Since I used the audio group also for providing the
> > realtime capabilities, I changed the group and mode of /dev/rtc to
> >   crw-rw----  1 root audio
> > But then it gives the following error message:
> >       cannot set tick on /dev/rtc: Unpassender IOCTL (I/O-Control)
> >          für das Gerät
> >       precise timer not available
> >
> > What is missing?  Do I have to update the provided muse to a newer
> > version?
> >
> > Uwe


More information about the Linux-audio-dev mailing list