[linux-audio-dev] compiling LADSPA for Mac OS X

Taybin Rutkin taybin at earthlink.net
Sun Apr 10 18:25:19 UTC 2005

I've just created a swh-plugins osx installer.  Would you like to try 
it out?



On Apr 10, 2005, at 1:12 PM, James McDermott wrote:

> hi steve,
> thanks for this...
>> I believe that you need to use the following CFLAGS:
>> -fno-common -flat_namespace -bundle -undefined suppress -lbundle1.o
> is that bundle1.o a placeholder i should replace with the name of a
> specific .o file? i'm guessing not.
> anyway, i tried these combinations of CFLAGS (one is the original plus
> the ones you suggest, the other is just $(INCLUDES) plus the ones you
> suggest):
> CFLAGS		=	$(INCLUDES) -Wall -Werror -O3 -fPIC -fno-common
> -flat_namespace -bundle -undefined suppress -lbundle1.o
> CFLAGS		=	$(INCLUDES) -fno-common -flat_namespace -bundle -undefined
> suppress -lbundle1.o
> and both give the same error (though the cc command printed by make
> looks different of course):
> [~/dev/ladspa_sdk/src] $ make
> cc -I. -fno-common -flat_namespace -bundle -undefined suppress
> -lbundle1.o -o plugins/amp.o -c plugins/amp.c
> cc: -lbundle1.o: linker input file unused because linking not done
> ld -o ../plugins/amp.so plugins/amp.o -shared
> ld: unknown flag: -shared
> make: *** [../plugins/amp.so] Error 1
> as you know, the LADSPA sdk doesn't come with a configure script which
> would generate the right compilation flags. but i'll look at the
> configure script in your plugin package and (if i can understand it!)
> maybe it'll give me what i need... thanks again.

More information about the Linux-audio-dev mailing list