[linux-audio-dev] light C++ set for WAV

Chris Cannam cannam at all-day-breakfast.com
Wed Jul 26 10:26:00 UTC 2006


On Wednesday 26 Jul 2006 11:12, Florian Paul Schmidt wrote:
> Well, it is very thin though. Which is not a bad thing at all. One could
> make ue of an arbitrary amount of more advanced C++ features if desired
> though (i.e. templates parametrized with the type you want to read for
> example, or operator<< and operator>> for reading and writing, etc.)

operator<< and >>... ugh.

> > Secondly, with regard to the method names, which do you prefer:
> >
> >     - OpenRead
> >     - openRead
> >     - open_read
>
> vote++, i never cared for the more java style methodName convention.

I think if your class is named LikeThis, then your method should be named 
likeThat (Java-style).  If your method is named like_this, then your class 
should be named like_that (STL-style).  Either is fine, but don't mix your 
dialects.

> > Since you're the only person who actually responded to the real
> > meat of my email, I have to assume that you are the only person
> > on this list with a love for C++ and hence the only one who
> > should have any real input on this issue ;-).
>
> Nicely worded :)

Mmm.  For what it's worth, I write mostly C++ but have no problem with using 
the libsndfile C API.  I don't really mind whether it has a C++ API as well 
or not.  So yes, you probably should ignore me.


Chris



More information about the Linux-audio-dev mailing list