[LAD] Can't load firmware on RME HammerFall DigiFace

Jörn Nettingsmeier nettings at folkwang-hochschule.de
Mon Apr 27 14:40:05 UTC 2009

Natanael Olaiz wrote:
> El 04/27/2009 07:44 AM, Florian Faber escribió:
>> Natanael,
>>>> Did the card work before or is this your first try?
>>> It works on Windows, and it worked on Ub. Intrepid (hdsploader just 
>>> complained about the .bin place, and I copied from the alsa source 
>>> package...).
>> It sounds like a problem with the cardbus driver. I've seen these
>> strange phenomena a dozen times, and it was always a problem with the
>> cardbus chipset/driver. 
>> If it worked with Intrepid (whatever that is), then please find out what
>> has changed since then. It is obviously not a problem with the hdsp
>> driver.
> Intrepid Ibex is the code name of Ubuntu 8.10 (hardy is 8.04). One of 
> the major differences is the kernel (2.6.27, I think), but the problem 
> is that is not RT patched, reason to use 8.10 (hardy) or 9.04 (jaunty) :(

does ubuntu have the /proc kernel config option enabled? if so, you will
find a file /proc/config.gz which contains the kernel configuration of
the ubuntu kernel.
now grab a recent kernel plus rt patches, unpack it, unzip that
config.gz into the kernel build directory and rename it to ".config".
then "make gconfig", select fully preemptible kernel (real time), then
"make bzImage modules", then (as root) "make modules_install install".

there you go. unless ubuntu has lots of patches in their kernel, you
should be able to drop the new one in without major hassles. the only
thing that doesn't work for me when replacing the kernel (on suse
systems) is suspend-to-ram, ymmv.

More information about the Linux-audio-dev mailing list