[LAD] [alsa-devel] 2.6.31.x vs. rme vs. alsa 1.0.22?

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Tue Feb 23 22:51:19 UTC 2010

On Tue, 2010-02-23 at 22:26 +0100, Florian Faber wrote:
> On 02/23/10 22:22, Paul Davis wrote:
> > On Tue, Feb 23, 2010 at 3:48 PM, Fernando Lopez-Lezcano
> > <nando at ccrma.stanford.edu> wrote:
> > 
> >> ALSA sound/pci/rme9652/hdsp.c:831: Hammerfall-DSP: wait for FIFO status
> > <= 0 failed after 30 iterations
> > 
> > this is bad, and i think may be related to your issues. this
> > timing-sensitive loop has always been a problem. it probably just
> > worked the 2nd time you tried a firmware load (by good luck).
> I wonder if this happens with the PCI interface as well or if this is
> just another CardBus-Fuckup. Once again.

One test later. Not the same environment, it is a desktop with a pci
card and a digiface (instead of a multiface). with the
patch that restores functionality to snd_hdsp seems to work fine:

$ dmesg | grep -i hdsp
ALSA sound/pci/rme9652/hdsp.c:678: Hammerfall-DSP: iobox found after
ALSA sound/pci/rme9652/hdsp.c:830: Hammerfall-DSP: wait for FIFO status
<= 0 failed after 30 iterations
ALSA sound/pci/rme9652/hdsp.c:695: Hammerfall-DSP: loading firmware
ALSA sound/pci/rme9652/hdsp.c:728: Hammerfall-DSP: finished firmware

After booting the card seems to work (it was disconnected from the
firewire wire while it was rebooting). But same problem with the wait
for FIFO failing. So maybe it is not so different after all. 

-- Fernando

More information about the Linux-audio-dev mailing list