[LAD] jackd and usb hub

Luis Garrido luisgarrido at users.sourceforge.net
Sat Oct 9 00:39:50 UTC 2010

Hi there!

My laptop's USB ports are busted, probably a combination of them not
being top quality in the first place and my Edirol UA-25 USB audio
interface occasionally draining a hefty amount of current to power up
a couple of large diaphragm mikes.

First I tried adding a 2-USB ports PCMCIA card, but PCMCIA (or pccard
or cardbus or however the heck it is called nowadays) won't supply the
necessary juice, so if you need more than 100 mA you must use an extra
cable to suck the remaining amperage from one of the no longer
existing motherboard's USB ports. Alas, therefore not a complete
solution for the fried port blues.

So now I am throwing a powered USB hub in. As long as I keep it to
ALSA usage there is no problem: I can record and playback with, for
instance, Audacity using the ALSA backend. But anytime I try to launch
jackd the daemon fails and I get this in /var/log/messages:

kernel: ALSA sound/usb/usbaudio.c:882: cannot submit datapipe for urb
0, error -28: not enough bandwidth

I've tried different jackd buffer configurations to no avail. Anyone
(I guess that means Clemens) has any idea about whether I can work
around this?

Thanks in advance for any insight. Cheers,


PS: Yup, I have forsaken any hope of anything resembling low latency
with this setup, at least whenever I need phantom. The laptop is
5-year old, but still does the job and, above all, has a matte LCD
screen. Nuff said. I am cringing in advance at the unavoidable moment
entropy will force me to watch my ugly mug reflection superimposed
over my code. The combined effect can be too much to bear.

More information about the Linux-audio-dev mailing list