[LAD] ALSA multi plugin and JACK xrun callbacks

bart at magnetophon.nl bart at magnetophon.nl
Wed Jun 20 19:51:27 UTC 2012

Hi Everybody,

My name is Bart, this is my first post here, though some have met me on IRC.
Thanks for making Linux audio what it is!
I started using Linux in 2004 with DeMuDi, and have never looked back.

I'm trying to get my pcm_multi to work without with jackd.
Some of you seem to have got this down, with or without "ghost xruns".
Jörn seems to imply in the quoted thread that tschack is the answer, but
it gives me the most xruns of all jack implementations.

Who has got this working?
Who want to help me get to the bottom of this?
Google has been a great help so far, but I'm not sure what to try or what
to google anymore. :(

So far I've tried:

*jackd1 (1:0.121.3+20120418git75e3e20b-2)

All tested with the 3 kernels mentioned below.

The nedko jack with the avlinux kernel sometimes goes without xruns for
quite a long while, but sometimes gives lots of them.
I haven't found the pattern behind it yet.

My system is fully tuned, according to realTimeConfigQuickScan.pl
the only exceptions:

cat: /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor: No such file
or directory
Checking CPU Governors... CPU 0: '' CPU 1: '' CPU 2: '' CPU 3: ''  - not good

I assume this is because my cpu's are running full speed.

Kernel with Real-Time Preemption... not found - not good
Checking if kernel system timer is set to 1000 hz... not found - not good

But I'm running 3.2.0-2-rt-686-pae #1 SMP PREEMPT RT Fri Jun 1 20:28:43
UTC 2012 i686 GNU/Linux.
I've also tried linux-image-3.0.32-avl-8 from avlinux, debian 3.2.0-2

Here is my .asoundrc:
I'm runing jack like this:
jackd -d alsa -r 44100 -p 4096 -d rme9636_64

The two rme9636 soundcards are on their own irq's, with priorities just
below the timers.

Jack with just one card works like a charm.

Is there any other info needed?

Thanks a lot,


On 01/14/2011 11:12 PM, Jörn Nettingsmeier wrote:
> On 01/14/2011 10:39 PM, Jörn Nettingsmeier wrote:
>> i had it crash once when loading a really demanding session, but with
>> another average ardour project, it has now played fine and without
>> glitches for 10 minutes or so, while the xrun count goes through the roof.
> alas. i spoke to soon:
> after i added a 6x1 convolver and an ambdec instance
> jack2 bails out reproducibly after a couple minutes more, with a
> "floating point exception". so more testing.
> meanwhile, i'd like to know what these xruns are, and i wouldn't be too
> surprised if the eventual crash is actually related to the message
> buffer or some internal error counter wrapping...

jack2 gets nervous when i use a session with four jconvolver instances:

JackPosixMutex::Unlock res = 1
Unknown request 4294967295
jackd: ../common/JackGraphManager.cpp:45: void
Jack::JackGraphManager::AssertPort(jack_port_id_t): Assertion
`port_index < fPortMax' failed.

the cpu is not maxed out, afaics.

tschack handles this scenario just fine, and it doesn't spew error
messages on the console. if i monitor it in qjackctl, the xrun count
increases at the usual rate, though.

btw: qjackctl becomes a major cpu burden in this pathological case.
lookes like it's the error messages. i've seen it at up to 40% of one core.

More information about the Linux-audio-dev mailing list