[LAD] New SVN version of LV2:AVW - Crashes Ingen

Aurélien Leblond blablack at gmail.com
Fri May 18 17:06:47 UTC 2012

>> I have been trying to use GDB to debug this issue.
>> Problem is, as the program crashing is Ingen, I get the information as to
>> where it crashes in Ingen, not where the problem lies in my plugin.
>> Would anybody have any ideas as to how to tacke this issue?
> If the plugin runs in a different process,
> it may be necessary to attach that process to gdb.
> Don't forget to compile with debug enabled.

Thanks for that.

I have tried to approach so far:
* gdb --args ingen -eg
I would then run my plugin, remove it, Ingen would crash, but I would
get the information as to why Ingen crashed.
I'm not even sure that GDB would see that it should debug the vco2.so as well

* gdb vco2.so
(vco2.so being the name of my plugin)
Now I start Ingen, get the PID, and use
attach 15674
in gdb (I tried with or without the plugin running).
I get the following error message in GDB:
   (gdb) attach 15764B
   Attaching to program:
/home/blablack/src/avw.lv2/build/avw.lv2/vco2.so, process 15764
   Could not attach to process.  If your uid matches the uid of the target
   process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
   again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
   ptrace: Operation not permitted.

I guess GDB is looking for the vco2.so when attaching...

So what stupid thing am I doing?

Thanks in advance for the help,


More information about the Linux-audio-dev mailing list