[LAD] ladspa: dlopen failed for tap ladspa plugins

Zlobin Nikita cook60020tmp at mail.ru
Sat May 17 20:15:18 UTC 2014

Hello. I began work on external plugin browser, which should later be adapted 
for other resource types (just like falktx's carla currently does).

For begining i adopted some source files from ladspa-sdk example listplugins 
tools, trying to get it only for ladspa. There is one bug, whose reason i 
can't understand: it crashes on tap_reflector.so, which is first scanned 
plugin from TAP collection.

Crash point is somewhere inside dlopen() call. But if i remove all code and 
try specially only dlopen this plugin, check result and exit, it simply 
returns NULL result, as on failure, and this is for all TAP plugins (exactly 
tried also tap_reverb.so and tap_echo.so); other plugins, e.g. g2reverb.so, 
are dlopen()'ed without problem.

As for carla - it discovers and loads TAP plugins. I can't find any 
differences in code - tried same flags as it uses (RTLD_NOW | RTLD_LOCAL).

Backtrace of scanning crash (gdb output) is in attachement (too long lines in 
email message are automatically wrapped - don't know, is it good to violate 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: listplugins.log
Type: text/x-log
Size: 21272 bytes
Desc: not available
URL: <http://lists.linuxaudio.org/pipermail/linux-audio-dev/attachments/20140518/a1b40bd5/attachment-0001.bin>

More information about the Linux-audio-dev mailing list