[LAD] build problem with ambix plugins + LV2

Matthias Kronlachner m.kronlachner at gmail.com
Mon Oct 13 19:16:16 UTC 2014

Hi Jörn,

thanks for the report, I did not check the Linux build for long time and 
I accidentally deleted the wrapper.
I fixed it, should build fine now.
(The wrapper is not part of the official JUCE distribution, it was 
written by Filipe Coelho.)

However, the GUI of the LV2 plug-ins does currently not work, therefore 
you have to use the native GUI of the host.
This is particularly a problem for the (binaural-)decoder, where you 
have to load a preset in the GUI in order to generate output.
You can build the plugins as standalone as well and connect the decoder 
via jack. You are used to that anyway, right :-)

It would definitely need someone else to fix Linux related problems, but 
you can still nag me if something's wrong.

Greets from Regensburg to Essen (I'm more close now...)

On 12/10/14 22:08, Jörn Nettingsmeier wrote:
> Hi Matthias,
> I'm trying to build your ambix plugin suite on Linux using the LV2 
> wrapper, which fails with the following problem during makefile 
> generation:
> CMake Error at CMakeLists_subprojects.txt.inc:104 (ADD_LIBRARY):
>   Cannot find source file:
> /local/build/ambix/JUCE/modules/juce_audio_plugin_client/LV2/juce_LV2_Wrapper.cpp 
>   Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm 
> .hpp
>   .hxx .in .txx
> Call Stack (most recent call first):
>   ambix_binaural/ambix_binaural/CMakeLists.txt:20 (INCLUDE)
> It seems that the JUCE tree in your repo does not have an LV2 
> directory at all, and neither has the official JUCE repo - has it been 
> dropped?
> Any hints much appreciated, best greetings from Essen to Vilnius,
> Jörn

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxaudio.org/pipermail/linux-audio-dev/attachments/20141013/082053c3/attachment.html>

More information about the Linux-audio-dev mailing list