[LAD] connect(2) call to /dev/shm/jack-0/default/jack_0 failed (err=No such file or directory) (again...)

Fokke de Jong fokkedejong at gmail.com
Wed Sep 12 15:09:08 CEST 2018

Hi all, 

Sorry to bother you again with this. I’m running into the same problem again as before (see the latter part of the [LAD] jackd not using jackdrc… thread). 
And apparently my last fix involved some magic rather than replicable logic… :-( i.e. the problem seems to have disappeared on that system, without knowing exactly why)

Now I am installing my jack client again on another fresh install of ubuntu 17.04. and a get the same error. 

I have installed jackd1, to be exact, these packages are current.

jackd/artful,artful,now 5 all [installed,automatic]
jackd1/artful,now 1:0.125.0-2 amd64 [installed]
jackd1-firewire/artful,now 1:0.125.0-2 amd64 [installed,automatic]
libjack0/artful,now 1:0.125.0-2 amd64 [installed]
qjackctl/artful,now 0.4.5-1ubuntu1 amd64 [installed,automatic]

when I start my client jackd is automatically started  but i get the error:

connect(2) call to /dev/shm/jack-0/default/jack_0 failed (err=No such file or directory)

By browsing the jack sources i found the message seems to come from libjack/client.c in server_connect() 

peeking into the /dev/shm directory it seems  /dev/shm/jack-0/default/jack_0  is briefly created,but disappears again, presumably just before the client is able to connect.

I have been breaking my head over this, but I really have no clue why this is happening, especially as this has worked fine in the past. 

I would really like to know what could possibly cause this error and how to fix it.


More information about the Linux-audio-dev mailing list