<div dir="ltr"><br><div class="gmail_extra"><br><br><div class="gmail_quote">On Fri, May 3, 2013 at 2:14 PM, Fons Adriaensen <span dir="ltr"><<a href="mailto:fons@linuxaudio.org" target="_blank">fons@linuxaudio.org</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I'm preparing a seminar that will take place tomorrow (4 May),<br>
it will involve live mixing of surround sound using Ardour.<br>
While setting up the PC to be used, two problems occured.<br>
<br>
The first one is solved, but its cause remains misterious.<br>
A some point it appeared that the sound card (HDSP-MADI,<br>
used every day since years) had decided to meet its creator.<br>
Every program trying to access it - from jackd to aplay -L<br>
not only blocked, but turned out to be impossible to kill.<br>
Replaced the card - same result. It turned out to be a<br>
corrupt /var/lib/alsa/asound.state. The systemd service<br>
doing the 'alsactl restore' while booting choked on it,<br>
blocked, and ¬†this apperently blocked all others trying<br>
to use the card later. What I don't understand is how alsactl<br>
exactly failed, and why these processes seemed to be immune<br>
to a 'kill -9'.<br>
<br>
The second one is an Ardour2 session that worked perfectly<br>
on another similar PC, but becomes completely unresponsive<br>
on the one to be used. It has four mono tracks and three<br>
10-channel ones, and little else. DSP load is not the problem,<br>
it's less than 15%. Things look like it's the graphics. When<br>
Ardour's playhead reaches the right end of the editor window,<br>
it takes something like 5 seconds for the editor display to<br>
update - everything seems to freeze during that time but audio<br>
is not interrupted. Same when trying to scroll or change the<br>
zoom factor. Video card is Nvidia GeForce 7300, indeed quite<br>
old, but the same PC does full-screen HD youtube videos without<br>
problem. Video driver is nouveau as nv seems to be no longer<br>
supported by Archlinux. I'm pretty sure this system didn't have<br>
such problems when it was using nv. OTOH nouveau works very well<br>
on other systems... I could try and install the proprietary<br>
Nvidia driver, but with just some hours to go I'd rather not<br>
take any risks...<br>
<br>
Any hints ?<br>
<br>
Ciao,<br>
<span class="HOEnZb"><font color="#888888"><br>
<br></font></span></blockquote><div><br></div><div>Fons, sorry if this reply didn't come in time, but FWIW, Non-Timeline can now import Ardour sessions (audio tracks and regions) and should have significantly faster graphics, esp. on older hardware.¬† <br>
</div></div><br></div></div>