[linux-audio-user] Anyone able to run Csound in Linux in real-time?

ico at fuse.net ico at fuse.net
Sun Mar 16 21:27:01 EST 2003

Hi all,

I've been messing with Csound recently in order to see whether csound can be used well in real-time settings. The problem is that I tried icsound and the other csound (forget the source) and neither were able to output anything in real-time.

I've used -o devaudio flag, also -W (for wave) output, and while my scorefile finished without any errors, I got no sound out.

If I try to do <csound call> > /dev/dsp I get garbage sound since the header is all screwed up by the verbose output of the csound process.

I am using latest ALSA and I compiled csound from scratch and still no luck.

So, I was wondering if anyone had any luck running it in real-time.

P.S. I've been also having a terrible time trying to compile externals in the icsound (i.e. OSCext and others). I get a huge number of errors and am not sure where the problems is stemming from.

Any help is greatly appreciated!


More information about the Linux-audio-user mailing list