[linux-audio-user] Trying to record audio from line in and additional questions

Sylvain Robitaille lau at therockgarden.ca
Sun Mar 23 13:55:01 EST 2003

First the vitals:

The computer system is a 400 MHz K6-2 with 512 MB memory, and a Hercules
Fortissimo II (Cirrus Logic Soundfusion CS4624 processor) sound card.
The OS is Linux-2.4.20 (built up from Slackware-8.0, with kernel patches
and package upgrades).  I have the following ALSA components installed:
alsa-driver-0.9.0rc7, alsa-oss-0.9.0rc1, alsa-utils-0.9.0rc7,
alsa-lib-0.9.0rc7, alsa-tools-0.9.0rc7.

The kernel is mostly monolithic, with the following options (abridged to
include only those I know are relevant; if folks want the complete
listing, I can easily provide it):


ALSA is the only component that I have modularized (only because I don't
have the impression it can easily be just built-in, actually), and the
following modules are loaded:

   Module                  Size  Used by
   snd-mixer-oss          11120   1 (autoclean)
   snd-cs46xx             58096   1 (autoclean)
   snd-pcm                50752   0 (autoclean) [snd-cs46xx]
   snd-timer               9392   0 (autoclean) [snd-pcm]
   snd-ac97-codec         26912   0 (autoclean) [snd-cs46xx]
   snd-rawmidi            11808   0 (autoclean) [snd-cs46xx]
   snd-seq-device          3824   0 (autoclean) [snd-rawmidi]
   snd                    27280   0 (autoclean) [snd-mixer-oss snd-cs46xx
                                    snd-pcm snd-timer snd-ac97-codec
                                    snd-rawmidi snd-seq-device]

I've been using Linux with OSS and a Media-Vision Pro-Audio-Studio-16
soundcard for years, and have basically had very little trouble with
that combination.  Upgrading to Linux-2.4.x caused the sound output to
be rather noisy, so I recently took advantage of the situation to buy a
new soundcard, and upgrade to using ALSA (which I've been wanting to do
so I can investigate certain rather exciting applications such as Ardour
and the new Rosegarden).

The applications I've been using for years with OSS, (notably Dap,
Mixviews, Aumix, and a few others) all appear to mostly be working fine,
presumably through the ALSA OSS emulation.  Aumixer now shows some
lables (PhoneIn and Video) which don't correspond to any inputs I have
on my soundcard, while some others (IGain and Line1) don't appear to
have any use, given the way I'm currently using the card (signal from a
hardware mixer going to the Line input, and signal from the main, front
line output going back to the mixer).

I can play back sound files without any problem.  In fact I've also tried
a few new (to me) applications, such as Audacity, ProTux, and (though
I'm having problems with it I won't cover here) Ardour, and they too
play back sounds quite nicely  (the sound is "grainy", though, perhaps I
need to investigate the Low-Latency issues more, or increase the size of
some buffer somewhere).

I can send sound to the computer, and listen to that sound coming back
from the computer (adjusting the level with the "line" level in Aumix,
for example), but if I try to record that sound (in any of the
applications I've tried, including all those listed above), with "record
enable" selected in Aumix, I get no audio recorded (silent sound file).

Also, I find it interesting to note that I can record-enable only one
input source at a time (contrary to my old Media-Vision card).  I'm
assuming that's a function of the hardware, though and can't be fixed in

Finally, we get to my questions:

  - Can someone point me in the right direction(s) to find a solution to
    this, so I can record audio (preferably from numerous sources) into
    my computer?  I'll be perfectly happy with pointers to documentation
    (though I expect to get at least some to documentation I've already
    read, because I think I've repeatedly gone through all the
    documentation I already found myself), and suggestions to upgrade
    certain components.

  - I've tried to start Jackd at system boot, with the following command
    added to my rc.local file:

      /local/bin/jackd -d alsa -d cs46xx -p 512 &

    Jackd fails to start at that point (I'm afraid I haven't noted the
    exact error message, but I can make a point of doing so next time I
    reboot the system), but it does start when run manually from a root
    shell.  Does anyone have any idea why jackd might not start at boot
    time, (perhaps the ALSA modules aren't loaded yet at that time)?  If
    I understand my boot sequence properly, kernel modules are setup
    (via "depmod -a") before rc.local is run, so the modules may not be
    loaded, but they should by that point be loadable (they load
    automatically by the kernel in regular use).

  - Is it possible to build ALSA into the kernel?

  - on a slightly unrelated point, my new soundcard has a built-in
    synthesizer with at least some features I'd like to explore.  Though
    I know this won't replace any of my hardware synths (or some of the
    software synths I've begun to play with), I'd like to play around
    with some of its built-in sounds, and probably use it (at least
    until I get something better) as my "preset playback" device,
    controlled from an external MIDI controller.  Does anyone have
    suggestions for how I might go about that?  (again, simple pointers
    to existing documentation would be more than appreciated).

    In case people are wondering about my specific intended application,
    I'd like to use a Roland Octapad to trigger percussion sounds from
    the soundcard's built-in synth.

Thanks in advance for any pointers people can provide....

Sylvain Robitaille                              syl at alcor.concordia.ca

Major in Electroacoustic Studies                  Concordia University
Faculty of Fine Arts / Music Department       Montreal, Quebec, Canada

More information about the Linux-audio-user mailing list