[linux-audio-user] ALSA 0.9.1 on IBM ThinkPad T20

Mark Knecht mknecht at controlnet.com
Mon Mar 31 14:08:00 EST 2003

   Check out PlanetCCRMA for getting RH 8.0 updated on a laptop. Fernando
has a specialized kernel I believe.



> -----Original Message-----
> From: linux-audio-user-admin at music.columbia.edu
> [mailto:linux-audio-user-admin at music.columbia.edu]On Behalf Of Greg
> Reddin
> Sent: Monday, March 31, 2003 10:41 AM
> To: linux-audio-user at music.columbia.edu
> Subject: [linux-audio-user] ALSA 0.9.1 on IBM ThinkPad T20
> Hey all,
> I'm sort of a Linux newbie.  I've been using Linux pretty much
> exclusively for a little over a month.  I've used and developed on
> Unix for several years, so much of it is familiar to me.
> Anyway, I got ALSA up and running fine on my desktop machine, but am
> having problems with my laptop.  I searched the web for days and
> can't seem to find consistent information, so I wonder if you guys
> could help.
> My laptop is an IBM Thinkpad T20 with a "Cirrus Logic CS-4614/22/24
> CrystalClear SoundFusion Audio Accelerator" soundcard.  I'm running a
> fairly "vanilla" installation of RedHat 8.0, meaning I didn't
> reconfigure the kernel or anything like that.  The kernel version is
> 2.4.18-14.  The OSS driver for cs46xx was installed, and I believe
> the sound test worked during installation.  But since then, audio has
> not worked at all.  XMMS will play,and you can see the meters
> popping, but no sound comes out of the speakers or headphones.
> I downloaded the ALSA 0.9.1 tarballs and ran through the
> installations.  The first problem I ran into was unresolved symbols
> due to symbol versioning in the kernel.  I fixed that by adding the
> following to the alsa-driver Makefile:
> CPPFLAGS += -include
>   /usr/src/linux-2.4.18-14/include/linux/modversions.h
> endif
> So, I did a make clean, reran the ./configure, make, make install,
> ./snddevices, and installed alsa-lib and alsa-util.  At some point I
> had to rmmod the cs46xx OSS driver because it complained that it was
> in use.  I also chmod'ed the /dev files as the doc suggested.
> I used gnome-alsamixer to unmute the channels and set levels.  At
> first alsaplayer would play a file (.wav or .mp3) and the meters
> would show activity, but no sound would be present.  Now, when I try
> to run alsaplayer, play, or xmms I get an error message that says
> "Cannot open device: /dev/dsp".
> So has anyone gotten ALSA 0.9.1 to work on this kernel?  Should I use
> a different ALSA package or a different kernel?  Any suggestions
> would be greatly appreciated.
> Thanks,
> Greg Reddin
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!
> http://platinum.yahoo.com

More information about the Linux-audio-user mailing list