[linux-audio-user] Problems with VST under linux

Kjetil Svalastog Matheussen k.s.matheussen at notam02.no
Sun Nov 23 05:29:49 EST 2003

axiom at sphereserver.sm:
> Hi all. I'm trying to get VST plugins run under linux (a RH9 with Planet
> CCRMA, kernel 2.4.22-6.ll.rh90).
> I've followed those steps:
> - downloaded wine 20031118
> - downloaded vstserver-0.2.8 (ladspavst too)
> - i've installed wine simply untar it, then ./wineinstall
> - i've compiled vstserver and ladspavst following their instructions
> - i've correctly set VST_PATH (if i do "cd $VST_PATH" it brings me to
> correct folder)
> Now, when I run vstserver, then open a sound application (Audacity, in
> example), i'll get this error:
> VSTSERVER/main: Vstserver 0.2.8 started. Waiting for requests.
> VSTSERVER/main: Going to try to start vst plugin "DFX Transverb.dll".
> wine: Unhandled exception (thread 0009), starting debugger...
> WineDbg starting on pid 8
> Loaded debug information from ELF 'wine' ((nil))
> No debug information in 32bit DLL 'F:\vstserver-0.2.8\vstservant'
> (0x40730000)
> No debug information in 32bit DLL 'NTDLL.DLL' (0x401c0000)
> No debug information in 32bit DLL 'KERNEL32.DLL' (0x40440000)
> Unhandled exception: page fault on read access to 0x409ffd80 in 32-bit
> code (0x4000c239).
> In 32-bit mode.
> 0x4000c239 (_end+0x400a40d): movl       0x0(%eax),%eax
> Wine-dbg>WineDbg terminated on pid 8

I'm surprised you got the latest wine version to work with the vstserver,
I didn't think it should work. Have to check it out.

> i've even tried with a wine version suggested by INSTALL of vstserver,

Yes, thats what you should do. :)

> but when it try to do last configuration step (next make, when it tries
> to write the first registry entries), wine going in a debug loop and no
> programs starts, even regedit.
I didnt understand that. What is happening at which configuration step?


More information about the Linux-audio-user mailing list