[linux-audio-user] Recording from Line-In

G Cote garyb at cotecorner.com
Sat Sep 6 15:58:01 EDT 2003

I'm having problems recording from line in.
Without knowing exactly what's going wrong, all I
can say is that I can only playback "silence."

As I'm recording, I can hear the audio being fed
back through the external speakers. I can also use
various mixers to mute/unmute and set the volume on
the "Line" setting. So I'm pretty sure everything is
hooked up right.

I initially tried using sox/notlame/mpg123 ...

# record and encode
$ sox -t ossdsp -w -r 44100 /dev/dsp -t cdr - |
  notlame -k -v -S - /tmp/out.mp3
# playback
$ mpg123 /tmp/out.mp3

I've since tried to simplify things ...
$ rec -d /dev/dsp /tmp/out.wav
$ play /tmp/out.wav

Neither of them work. 

System details are provided below. What else can
I do to troubleshoot this?

Thank in advance

 - gary

. redhat 8.0 (2.4.20-19.7)
. alsa-0.9.6
. Turtle Beach Santa Cruz sound card

$ lspci
00:0b.0 Multimedia audio controller: Cirrus Logic CS
4614/22/24 [CrystalClear SoundFusion Audio
Accelerator] (rev 01)

$ lsmod
Module                  Size  Used by    Not tainted
snd-seq-midi            5312   0 (autoclean) (unused)
snd-seq-oss            34720   0 (unused)
snd-seq-midi-event      6048   0 [snd-seq-midi
snd-seq                47280   2 [snd-seq-midi
snd-seq-oss snd-seq-midi-event]
snd-pcm-oss            45284   0
snd-mixer-oss          16408   1 [snd-pcm-oss]
snd-cs46xx             80636   1
snd-rawmidi            18656   0 [snd-seq-midi
snd-seq-device          6284   0 [snd-seq-midi
snd-seq-oss snd-seq snd-rawmidi]
snd-ac97-codec         50264   0 [snd-cs46xx]
snd-pcm                85344   0 [snd-pcm-oss
snd-timer              19588   0 [snd-seq snd-pcm]
snd                    43108   0 [snd-seq-midi
snd-seq-oss snd-seq-midi-event sn
d-seq snd-pcm-oss snd-mixer-oss snd-cs46xx snd-rawmidi
snd-seq-device snd-ac97-c
odec snd-pcm snd-timer]
soundcore               6372   8 [snd]
gameport                3440   0 [snd-cs46xx]
snd-page-alloc          9876   0 [snd-cs46xx snd-pcm]

$ cat /etc/modules.conf

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-cs46xx
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Gary Cote
gary at cotecorner.com

More information about the Linux-audio-user mailing list