[linux-audio-user] Re: RME hammerfall DSP Multiface: help needed

Robert Epprecht epprecht at solnet.ch
Mon Sep 8 17:59:01 EDT 2003

Patrick Shirkey <pshirkey at boosthardware.com> writes:

> Robert Epprecht wrote:
>> I just run hdsploader a few times (until it gives no errors, which
>> means at least two times, sometimes three)

> Bad idea. It should work the first time without errors or you can't
> trust it IMO.
> I found similar errors to you until I decided to load the modules
> manually before running hdsploader.

> I run this script [ ... ]

Hmm I tried to test, but realised that it will take me some more
time to understand exactly how Debian loads the ALSA modules.
I thought I had them disabled, but lsmod proved me wrong...

So I tried a simple quick test, which I think should (could?) have
the same effect:  I manually unloaded the modules in question after
booting, checked with lsmod and then and run your script adapted to
my card#. I even did try to unplug the Multiface cable in between on
some of my tests, just to try everything I could imagine could possibly
help). But hdsploader returned with the same error message as it always
does when I start it the first time.

Running the routing and level setting part of the script after running
hdsploader again did not solve the problems either.

Do you think it could make a difference when the modules have been
loaded already on boot up, but removed later on?

Thanks a lot for the input,

More information about the Linux-audio-user mailing list