[linux-audio-user] Re: RME hammerfall DSP Multiface: help needed

Patrick Shirkey pshirkey at boosthardware.com
Mon Sep 8 22:05:00 EDT 2003

Robert Epprecht wrote:
> Hmm I tried to test, but realised that it will take me some more
> time to understand exactly how Debian loads the ALSA modules.
> I thought I had them disabled, but lsmod proved me wrong...
> So I tried a simple quick test, which I think should (could?) have
> the same effect:  I manually unloaded the modules in question after
> booting, checked with lsmod and then and run your script adapted to
> my card#. I even did try to unplug the Multiface cable in between on
> some of my tests, just to try everything I could imagine could possibly
> help). But hdsploader returned with the same error message as it always
> does when I start it the first time.

That's good to know it's consistent. Sounds like a firmware bug to me 
too now. One other thing which you may not have tried is booting m$ then 
warmbooting into linux (don't turn off the machine between boots). I 
just remembered that with older versions ofthe driver this was the only 
way to get the multiface to work.

I can't remember if you are running cvs or not (probably no).

> Do you think it could make a difference when the modules have been
> loaded already on boot up, but removed later on?

They shouldn't as long as you remove them before running hdsploader :)


Patrick Shirkey - Boost Hardware Ltd.
Http://www.djcj.org - The Linux Audio Users guide

Being on stage with the band in front of crowds shouting, "Get off! No!
We want normal music!", I think that was more like acting than anything
I've ever done.

Goldie, 8 Nov, 2002
The Scotsman

More information about the Linux-audio-user mailing list