[linux-audio-user] system plays cdrom, put not audio files

ed orphan millward at Ms.UManitoba.CA
Sun Dec 12 04:26:38 EST 2004

Asus A7N8X motherboard on-board sound circuit.
nForce2 AC97 Audio Controler
Slackware 10  kernel 2.4.26    ALSA
KDE Control sound system is set to autodetect
    The sound  worked 2 days ago, but then, bang!
Won't play audio files no more. Somebody ( not me! ) must have
goofed up somewhere. ( Well, maybe me, I don't know )
    The cdrom plays audio CDs Ok with KDE KsCD player
so I know something is working right. But the nForce2 AC97
sound mixer must have AUX set high. The Master Volume
and PCM on the mixer have no effect on cd-rom volume.
But no programs play audio files, including the usual
KDE system sounds the mouse used to make.
   I have checked all the /dev devices and they all
look good. The correct driver ( snd-intel8x0) is loaded.
   When KDE starts it gives an error message:
"Sound server Error while initializing the sound driver
device fault can't be opened for playback ( no such device)
The sound server will continue, using the null open device."
/usr/bin/audacity  in KDE gives this warning when
starting up:
  "There was an error initializing the audio I/O layer.
  You will not be able to play or record audio."
Try to play a loaded file and audacity says:
    "Error while opening sound device. Please check the
    output device settings and project sample rate."
The Gnome Wave Cleaner is also silent and hangs
when I press the play button.
     The Sox play comamnd is silent.
I have tried all kinds of changes to /etc/modules.conf
to the ALSA settings and used the alsaconf command
a few times too, but my knowledge is limited and nothing
good happens.  This is my  /etc/modules.conf

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.5 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---

 These are my  loaded modules  ( lsmod )
Module                    Size       Used by         Not tainted 
snd-seq-midi               3488   0  (autoclean) (unused)
snd-seq-midi-event      3264   0  (autoclean) [snd-seq-midi]
snd-seq                33424   0  (autoclean) [snd-seq-midi       snd-seq-midi-event]
snd-pcm-oss            37736   0
snd-mixer-oss          12504   0  [snd-pcm-oss]
usb-ohci               19240   0  (unused)
ehci-hcd               17580   0  (unused)
usbcore                59308   1  [usb-ohci ehci-hcd]
forcedeth               9164   1
snd-intel8x0           18924   0
gameport                1420   0  [snd-intel8x0]
snd-pcm                56072   0  [snd-pcm-oss snd-intel8x0]
snd-timer              13604   0  [snd-seq snd-pcm]
snd-page-alloc          6328   0  [snd-intel8x0 snd-pcm]
snd-ac97-codec         49500   0  [snd-intel8x0]
snd-mpu401-uart         3200   0  [snd-intel8x0]
snd-rawmidi            12740   0  [snd-seq-midi snd-mpu401-uart]
snd-seq-device          3888   0  [snd-seq-midi snd-seq snd-rawmidi]
snd                    30852   0  [snd-seq-midi snd-seq-midi-event snd-seq snd-pcm-oss s$
soundcore               3396   4  [snd]
ide-scsi                9328   0
agpgart                43940   0  (unused)

 One day it works great, the next day its crap. I don't know
what happened. Anybody got any ideas?



More information about the Linux-audio-user mailing list