[linux-audio-user] Which kernel for low latency and kernel 2.6.1-mm# problems

Glenn McCord clari_player at paradise.net.nz
Tue Jan 20 18:14:24 EST 2004

I adjusted some things. For me the realtime patch didn't work so I 
reverted back to modifying capabilities.h by hand.
<*> EMU10K1 (SB Live! & Audigy, E-mu APS) is now the only audio PCI 
device selcted.
I also double-checked to make sure
CONFIG_PREEMPT (Processor tyoe and features -> Preemptibel Kernel)
CONFIG_RTC (Character Devices -> Enhanced Real Time Clock)
CONFIG_SND_RTCTIMER (Sound -> Advanced Linux Sound Architecture -> RTC 
Timer support)
were built in.

I then install alsa-lib and alsa-utils 1.0.1 using the gentoo ebuilds.

I compiled jack from source with:
./configure --enable-optimize --with-gnu-ld --enable-capabilities 
--enable-stripped-jackd --with-default-tmpdir=/mnt/ramfs

I run jack with:
jackstart -R -v -d alsa -d hw:0

...and I get xruns whenever I open a program, move windows around. Hell 
sometimes it does it when I'm just looking at it. More specifically, if 
I want to record in ardour, jack chokes up an xrun after about 2 seconds.

Now, if I whip up my 2.4.2 with Andrew Morton's Low latency patch, 
install alsa-lib, alsa-driver and alsa-utils version 1.0.1with the 
gentoo ebuilds, then compile jack like above... presto, no problems.
So I'm thinking somethings missing in the kernel somewhere. Or perhaps 
the system settings are disagreeing with the way the kernel is setup.

Someone mentioned the /etc/modules.conf and the /etc/modprobe.conf so I 
attached it to the email in case there is something damning there that 
I've missed.

Also, does anyone use an ~/asoundrc or /etc/asound.conf file? I don't 
have one. I used to, but it's... disappeared...


James Stone wrote:

>On Tue, Jan 20, 2004 at 12:45:06AM +0100, martijn wrote:
>>Once upon a Mon, Jan 19 2004, Jack O'Quin hit keys in the following order:
>>>You are correct.  JACK's ./configure has no --enable-realtime option.
>>>Martijn probably means the --realtime option of jackd (same as -R).
>>True. I was thinking of --enable-capabilities and the realtime security module
>>and something mixed up in my brain.
>>something else, has anyone got 2.6.1 with a version of Andrew Morton's patch
>>branch working? I wanted to upgrade to alsa 1.0.1 and that seemed to be the
>>easiest way, but the first buffer that get's filled starts looping until i
>>close the soundcard programmatically. like if there's an interrupt conflict or
>>something... I have an Audiophile 2496 (ice1712) on an Asus a7v333-x. o and i'm
>>totally sure there's no interrupt conflict in my system. Everything works fine
>>with an unpatched 2.6.1 though... Has anyone with the same hardware/kernel
>>combo got this to work?
>Yep I am running 2.6.1mm4 but with a SBLive. The only problems I had were
>related to running the kernel modules with the old version of alsa
>(Oh apart from some kernel panics which occurred when the computer tried
>to remove snd_usb_audio at shutdown when my usb midi keyboard was on..
>had to change the shutdown script to solve that one..)
>Doesn't the a7v333-x have an Nforce chipset or some such?  I think there
>are problems with this chipset at the moment.
>I must say that though 2.6.1 is very nice, it does seem a little buggy
>for a stable release.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: modules-and-modprobe.tar.gz
Type: application/x-gzip
Size: 2806 bytes
Desc: not available
Url : http://lists.linuxaudio.org/pipermail/linux-audio-user/attachments/20040120/fe21f857/attachment.bin 

More information about the Linux-audio-user mailing list