[linux-audio-user] re: jackmix build error

Fernando Pablo Lopez-Lezcano nando at ccrma.Stanford.EDU
Wed Jul 21 00:23:18 EDT 2004

On Mon, 2004-07-19 at 05:35, Arnold Krille wrote:
> On Monday 19 July 2004 02:29, Ryan wrote:
> > I don't have any .la files.
> Ah should have been .so files...
> > I commented out -lXext and it still failed with the same error.
> Ehm, than the commenting should not work if you remove -lXext from the 
> command-line and and it still complains about not finding libXext.so...
> Are there only Redhat-users affected by this?

I managed to build it on rh9/fc1/fc2. What I did is to add an explicit
path to -L/usr/X11R6/lib in all places in the Makefile where -lXext is
found (plus the selectedId change suggested by Rui). That seems to have
done it. 

But I get strange behavior in FC2 (I'm testing at home in my laptop so I
can't test on rh9). If I run jack from the command line alone all is
well. If I start jack through qjackctl, or if I have jack running in a
terminal and start qjackctl, jackmix segfaults on startup...

This is what jack prints:
client JackMix error: awake_at = 2259745444 state = 2 timed_out = 2
I don't know if this is of any use, probably not:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -154948688 (LWP 3201)]
jack_set_process_callback (client=0x0, callback=0, arg=0x0) at
1866            if (client->control->active) {
(gdb) back
#0  jack_set_process_callback (client=0x0, callback=0, arg=0x0)
    at client.c:1866
#1  0x0805950c in QMemArray<char>::detach ()
#2  0x080592b8 in QMemArray<char>::detach ()
#3  0x0805ace3 in JackMix::process ()
#4  0x004d4099 in jack_client_thread (arg=0x8178380) at client.c:1164
#5  0x00b5698c in start_thread () from /lib/tls/libpthread.so.0
#6  0x009d816a in clone () from /lib/tls/libc.so.6

-- Fernando

More information about the Linux-audio-user mailing list