[linux-audio-user] RE: Major problem with RME HDSP/Multiface and a 64-bit AMD laptop - linux

thewade pdman at aproximation.org
Sun Mar 21 10:51:31 EST 2004


I see that you are having trouble using the multiface and cardbus in linux, on a 64-bit laptop no less. I am indeed covetious, I too am looking to buy an AMD 64 laptop, but I see only two: the ACI warrior, and the raptor 64; and both seem to me to be not there yet. Perhaps when alienware builds one...

As for linux, you are no doubt running the 2.6 kernel? 2.6 is fully capable of running in 64-bit mode (AFAIK) so it would seem folly not to run it, esspecially as it runs faster overall for me, even on my old 32-bit dell i8000.

Back to your question: I am also running linux (2.6) and using the hdsp/multiface with no problem. To get it running I : 
(a) downloaded the newest drivers from alsa-project.org. In linux 2.6, the alsa drivers are built into the kernel, so if you download the newest kernel (Im running 2.6.3), make xconfig, and set up audio, and kernel preempting, and such youll be halfway there.
(b) build the alsa utils and tools. In the tools is the hdsploader and hdspmixer.
(c) run alsaconf and then edit your modprobe.conf (replacement for modconfig, if I remember correctly). Heres mine:
alias eth0 e100

include /etc/modprobe.conf.dist
install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias usb-controller uhci-hcd
alias ieee1394-controller ohci1394

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.3 ---
alias snd-card-0 snd-maestro3
alias sound-slot-0 snd-maestro3
alias snd-card-1 snd-hdsp
alias sound-slot-1 snd-hdsp
# --- END: Generated by ALSACONF, do not edit. ---

I had alsaconf set up the maestro3 and then I edited this file (despite what it said) and added the hdsp

Once you build the above, reboot with the new kernel and as all the daemons are loading you should see the kernel print that it found the hammerfall cardbus and is waiting for firmware. When finally logged in, run hdsploader, and then hdspmixer to unmute the card and set levels, then your ready to go!

A few notes: I havent been able to get most sound apps tu run in alsa mode, PD I run through jack, and jack I run using alsa, but xmms and gxine for example I run in oss emulation.

Could you send me (perhaps off list) any information you have about your laptop, where you got it and about how much it ended up costing? I dont have the money to buy one now (well, not the credit space that is, theres no way I would have $3000 just sitting around), but I figure buy the time i do, Alienware(.com) might have one built. They seem to have good machines there.

Thanks, and good luck,

More information about the Linux-audio-user mailing list