[linux-audio-user] Compiling jack_FST

motorhammer motorhammer at bluewin.ch
Sat Nov 27 17:16:26 EST 2004

Thanks a lot for your replies.

Now Jack works fine with Real Time priority. I tested it with Rosegarden, 
Hydrogen and a midi keyboard.
Just for the tip, when using Suse (may work on other distro...I don't know) 
instead of "installing" LSM, just install the package "rtstools". This allow 
root to set priority on a running application throught its PID process.
The "SUSE LINUX – User Guide" explain how to use it. It's in chapter 
"Buffering and Latencies".

Ok, jack run fine, but not jack_fst.

When I run jack_fst as a user, it returns me these errors:
 -:58: error: unexpected character `{', expected character `}'
 -:58: error: unexpected character `{', expected character `}'

And when I run it as root, it returns me no errors, but the kernel crash 
completely ! The VST gui start fine, and then the system crash. I can just 
move the mouse. No errors are returned.
After rebooting, I'm must restart my sound system throught YAST (Suse control 
panel) to have sound. So It seems to be in relation with sound drivers......I 
don't know--

Any idea ?

(Sorry for my bad english !)

More information about the Linux-audio-user mailing list