[linux-audio-user] [OT] disk recovery problem

Cournapeau David cournape at enst.fr
Tue Feb 1 08:07:06 EST 2005

Kristian Rink wrote:

>Hi David;
>On Mon, 31 Jan 2005 14:45:28 +0900
>David Cournapeau <cournape at enst.fr> wrote:
>>partition is not mounted for sure, and I tried several other tempory 
>>locations, without any success. The "funny" part is that a fsck.ext3 
>>/dev/hda12 doesn't give me any error when I check the filesystem
>>(which let me some hope about the possible recovery).
>Have you tried booting off a live cd (like Knoppix) and accessing the 
>partition from there? 
I don't need it, because all my system partitions are fine. Only the two 
last partition, where there are some audio and work data, refused to be 

>You might want to check out gpart to guess partition beginning/end
>boundaries. In worst case, you might try an "mke2fs -S" followed by an
>e2fsck in that drive (chances are you get some data off this one). But
>overally I don't really think this is an issue caused by a broken
>partition table. How does cfdisk see the drive in question?
I think it is a partition table problem because I had the problems after 
having modified it through cfdisk. And the weird thing is that I could 
check the fs on the partition (a forced check didn't give any errors).

In fact, now that my problem is solved, I think I forgot to reboot after 
having modified the partition table; worse, I built a filesystem on the 
modified partition before rebooting, maybe a 40 Gb fs on a 2 Gb partition !

I didn't know how to use gpart on the extended partition.

What I did is just removing all the partitions from the partition table, 
and set the partitions where I knew the beginning/end. It worked, and I 
quickly copied all data on an external hard drive before reformating the 
partitions where the fs size and the partition size were different.

Thanks for you help,


More information about the Linux-audio-user mailing list