[linux-audio-user] USX2Y rawusb mode

Spencer Russell Spencer.Russell at oberlin.edu
Thu Mar 3 10:32:15 EST 2005

On Thu, Mar 03, 2005 at 12:41:17PM +0100, Karsten Wiese wrote:
> can you check if this error doesn't happen, when modprobing like 
> 	$ modprobe snd_usb_usx2y nrpacks=4
> ?
> nrpacks=1 and "rawusb mode" are irrelevant if you run jack with moderate latencies
> as above "-p1024 -n2" and 2 inputs.

With nrpacks=4, it seems to last slightly longer before giving
the "Sequence Error!" and "Most propably some urb of usb-frame
935 is still missing"

> What kernel are you using? If its not 2.6.11 you might give that a try.

Every time I've tried using a 2.6 kernel on this machine, I get
these random lockups that I can't figure out, so I'm using 2.4.26
with lowlatency, preempt, and givecap patches. I'll try 2.6.11,
and see how that goes.

Rui said a while ago that he was getting a similar message, until
he tuned the IRQ priorities, but I've been googling around and I
can't figure out how to do it. I tried
chrt -f -p 90 'pidof "IRQ 0"'
as directed on some website, but it just returns

execvp: No such file or directory
failed to execute pidof "IRQ 0"

I'm still not exactly sure what it is I'm trying to do with this,
I'm just sort of blindly following what I read on the
internet(always a good idea). The man page doesn't say anything
about IRQs, so if anyone wants to throw some help my way, that'd
be great.

> have fun
> Karsten

Thanks a lot for the help!

More information about the Linux-audio-user mailing list