[linux-audio-user] Line6 POD XT Live

Robert Jonsson rj at spamatica.se
Sun May 1 09:57:30 EDT 2005


On Sunday 01 May 2005 09:20, Noah Roberts wrote:
> On 4/16/05, Markus Grabner <grabner at icg.tu-graz.ac.at> wrote:
> >         Hi POD users!
> >
> >     I just read your messages about using the POD XT Live under Linux. I
> > am very curious if this actually worked since Line6 told me about
> > modifications in the audio interface made for the POD XT Live, which I
> > blindly added to the driver without testing since I don't own a POD XT
> > Live. Please let me know if you were successful, and if not, what exactly
> > went wrong (syslog etc.), so I can try to fix it.
> Well, it wouldn't build for one thing:

Haven't tried it yet, didn't know it was at all possible to create a driver 
for it even!
It does build just fine on my system though.  Kernel 2.6.12rc2<yadayadayada>

I'm unable to find _any_ reference to the `snd_podxtpro_audio_t_magic'. 
Possibly the _magic is appended by some macro, the rest is available... 
Possibly it's kernel dependent...

Try unpacking the files again, perhaps there was a mismatch with some source?

> make -C /lib/modules/2.6.5-gentoo-r1/build
> SUBDIRS=/home/nroberts/podxtpro-0.3 modules
> make[1]: Entering directory `/usr/src/linux-2.6.5-gentoo-r1'
> *** Warning: Overriding SUBDIRS on the command line can cause
> ***          inconsistencies
> make[2]: `arch/x86_64/kernel/asm-offsets.s' is up to date.
>   CC [M]  /home/nroberts/podxtpro-0.3/audio.o
> /home/nroberts/podxtpro-0.3/audio.c: In function
> `snd_podxtpro_control_get': /home/nroberts/podxtpro-0.3/audio.c:62: error:
> `snd_podxtpro_audio_t_magic' undeclared (first use in this function)
> /home/nroberts/podxtpro-0.3/audio.c:62: error: (Each undeclared
> identifier is reported only once
> /home/nroberts/podxtpro-0.3/audio.c:62: error: for each function it appears
> in.) /home/nroberts/podxtpro-0.3/audio.c: In function
> `snd_podxtpro_control_put': /home/nroberts/podxtpro-0.3/audio.c:73: error:
> `snd_podxtpro_audio_t_magic' undeclared (first use in this function)
> /home/nroberts/podxtpro-0.3/audio.c: In function `cleanup_audio':
> /home/nroberts/podxtpro-0.3/audio.c:207: warning: implicit declaration
> of function `usb_kill_urb'
> make[2]: *** [/home/nroberts/podxtpro-0.3/audio.o] Error 1
> make[1]: *** [/home/nroberts/podxtpro-0.3] Error 2
> make[1]: Leaving directory `/usr/src/linux-2.6.5-gentoo-r1'
> make: *** [default] Error 2
> nroberts at bart podxtpro-0.3 $ grep -n snd_podxtpro_audio_t_magic *
> nroberts at bart podxtpro-0.3 $
> Install txt doesn't say anything about needing any other packages...


More information about the Linux-audio-user mailing list