[linux-audio-user] Line6 POD XT Live

Noah Roberts roberts.noah at gmail.com
Mon May 2 01:10:14 EDT 2005

On 5/1/05, Noah Roberts <roberts.noah at gmail.com> wrote:
> On 5/1/05, Noah Roberts <roberts.noah at gmail.com> wrote:
> > On 5/1/05, Noah Roberts <roberts.noah at gmail.com> wrote:
> > > On 5/1/05, Robert Jonsson <rj at spamatica.se> wrote:
> > >
> > > > Haven't tried it yet, didn't know it was at all possible to create a driver
> > > > for it even!
> > > > It does build just fine on my system though.  Kernel 2.6.12rc2<yadayadayada>
> > >
> > > Ok, I will try updating kernel later.  What gcc you using?
> > >
> >
> > kernel update did the trick.  Now have to see if it actually works.
> > Loaded ok anyway...
> >
> No.  The podxtpro module doesn't seem to work with the live.  I get an
> oops as soon as I activate a connection to the pod.

Damnit, hit a shortcut key on accident and sent an incomplete oops.

Here is a complete one:

usbcore: registered new driver podxtpro
usb 4-2: new full speed USB device using uhci_hcd and address 2
podxtpro 4-2:1.0: Line6 PODxt Live found
podxtpro 4-2:1.0: Line6 PODxt Live now attached
podxtpro 4-2:1.1: Line6 PODxt Live found
Unable to handle kernel NULL pointer dereference at 0000000000000040 RIP: 
PGD 3e934067 PUD 3ea22067 PMD 0 
Oops: 0000 [1] 
CPU 0 
Modules linked in: podxtpro uhci_hcd snd_seq_midi snd_ioctl32 snd_pcm_oss snd_mi
xer_oss snd_seq_oss snd_seq_midi_event snd_seq snd_ens1371 snd_rawmidi snd_seq_d
evice snd_ac97_codec snd_pcm snd_timer snd soundcore snd_page_alloc usbcore 8139
Pid: 1122, comm: khubd Not tainted 2.6.11-gentoo-r6
RIP: 0010:[<ffffffff880c92f3>] <ffffffff880c92f3>{:podxtpro:cleanup_audio+35}
RSP: 0018:ffff81003e9e3c28  EFLAGS: 00010296
RAX: fffffffffffffff0 RBX: 0000000000000007 RCX: ffff81003f13aec0
RDX: 00000000001af408 RSI: 00000000000000d0 RDI: ffff81003d26fe00
RBP: 0000000000000000 R08: ffff81003d9b8840 R09: ffff81003d0e3280
R10: ffff81003ce5cb80 R11: 0000000000000000 R12: 0000000000000007
R13: ffff81003cba9428 R14: ffff81003d26feb8 R15: ffffffff880cdfa4
FS:  00002aaaab01f060(0000) GS:ffffffff804198c0(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000000000000040 CR3: 000000003eb83000 CR4: 00000000000006e0
Process khubd (pid: 1122, threadinfo ffff81003e9e2000, task ffff81003f4d07e0)
Stack: ffffffff880ce0d7 ffff81003cba9428 ffff81003d26fe20 ffff81003d26fe20 
       ffff81003d26fe00 ffffffff880cc943 ffff81003d26fe00 ffff81003cba9428 
       ffff81003d9b88e8 ffffffff880ccf53 
Call Trace:<ffffffff880cc943>{:podxtpro:destruct+35} <ffffffff880ccf53>{:podxtpr
       <ffffffff8019e505>{sysfs_new_dirent+37} <ffffffff88007089>{:usbcore:usb_p
       <ffffffff8024dd5d>{driver_probe_device+77} <ffffffff8024dde3>{device_atta
       <ffffffff8024e101>{bus_add_device+97} <ffffffff8024ceb4>{device_add+148} 
       <ffffffff8019e589>{sysfs_make_dirent+41} <ffffffff88009623>{:usbcore:usb_
       <ffffffff8800a84b>{:usbcore:hub_events+571} <ffffffff8800a935>{:usbcore:h
      <ffffffff80143550>{autoremove_wake_function+0} <ffffffff80143550>{autorem
       <ffffffff8012c731>{schedule_tail+17} <ffffffff8010ebdb>{child_rip+8} 
       <ffffffff8800a910>{:usbcore:hub_thread+0} <ffffffff8010ebd3>{child_rip+0}

Code: 48 8b 7c dd 08 48 85 ff 74 13 e8 3e 37 f4 ff 48 8b 7c dd 08 
RIP <ffffffff880c92f3>{:podxtpro:cleanup_audio+35} RSP <ffff81003e9e3c28>
CR2: 0000000000000040
Tried with both preempt in and out.  This is amd64 in 64 mode.

More information about the Linux-audio-user mailing list