[linux-audio-user] Update on savihost + Vsti's under wine

Nigel Henry cave.dnb at tiscali.fr
Wed Nov 9 13:52:43 EST 2005

On Wednesday 09 November 2005 06:41, Hector Centeno-Garcia wrote:
> Nigel Henry wrote:
> >Hi Mark. Right. Here goes. This is on FC2, not Gentoo. I'll have  a go on
> >Gentoo when I get the time. Wine is version 0.9-1fc2winehq, savihost is
> >version 1.23. I borrowed mfc42.dll from my XP install and put it
> >in .wine/drive_c/windows/system32. Savihost.exe I put in the program
> > files, and also put Lin-Plugs FreeAlpha synth's .dll in there. Renamed
> >savihosts .exe to FreeAlpha, and it worked first go. Now FreeAlpha synth
> > has a separate file for it's patches. it will only use the default patch
> > that is on the synth But it works. I've been trying a lot of freebie
> > synths, and notice that they use  a lot of cpu. Ksim is showing, when
> > idle, between 70 & 80% cpu useage, and yet the synth itself only shows
> > less than 5% cpu useage. VirSyn's MicroTERA. a free synth uses 100% cpu.
> > Not enough to freeze the mouse, and even though I did get some sounds out
> > of it, it would not load the sound bank. Native Instruments Reactor
> > Session One 4.0, another freebie fully operational synth. When installed,
> > this has a .exe and a .dll. Running the .exe brings up the GUI, but the
> > only menu item that works is the one for sample rate, so cannot connect
> > usb midi keyboard or audio output. The .dll through savihost works fine,
> > but again at idle, is showing 50% cpu on Ksim, and the synth is showing
> > about 18.8%. The complete patch bank is available on this synth. Single
> > notes play ok, but push the cpu on Ksim to about 95%. Chords push the cpu
> > useage to 100%+ and become quite broken up. All in all, I'm very happy
> > with the way this is going. Hardly anything worked on
> > wine-20041019-1fc2winehq, but 0.9-1fc2winehq has certainly made more
> > things work. One observation. I tried crystal.dll on numerous occasions,
> > and it would not open. At that time only mfc42.dll was in the system32
> > directory. After installing Reactor Session One synth, and perhaps
> > something else, more .dll's turned up in system32. I thought I'd try
> > crystal synth again, and this time it worked. The extra .dll's are listed
> > below.
> >msvcirt.dll
> >Msvcrt.dll
> >
> >Here are a few of the freebie synths I tried, and which worked ok with
> >savihost.
> >Triangle I & Triangle II from http://www.rgcaudio.com
> >Interruptor Dub Siren from http://www.interruptor.ch
> >JXPlugins JX220 from http://www.jxplugins.co.uk
> >LFObia Mocheese from http://www.electronicscene.com/elektracidz
> >LRsynths Trionimox from http://www.alphastrike.de
> >Psychic Modulation Pandemonium from http://www.psychicmodulation.com
> >Tobybear Screamer  from http://www.tobybear.de
> >LinPlug Free Alpha from http://www.linplug.com
> >
> >I'd be really interested in knowing why these synths use so much cpu when
> > just lying idle. Nigel.
> >
> >Machine: Aiii-friend 1.3Ghz, 1GB Ram, Audigy2 soundblaster, Built-in
> >Cyberblade i1 graphics.
> Good testing! I've been using xfst and seems to work pretty fine. There
> are some VSTs that wont load but much less than with fst and
> wine20040505. Have you been using Jack? It seems that there are lots of
> problems with the Wine-Jack combo.
> cheers!
> Hector.
Hi Hector. No I'm not using Jack with Wine, but Alsa. I must admit that I'm 
quite impressed with savihost's ability to run all the VSTi's that I tried, 
apart from Plugsound Free. There is a pretty bad latency problem when using 
my Evolution MK-225C usb midi keyboard. Some synth patches seem to allow for 
more latency than others. It can be a bit like playing a pipe organ. Press 
the key. Have a quick fag, and wait for the sound to arrive. Nigel.

More information about the Linux-audio-user mailing list