[linux-audio-user] terrible sineshaper dependencies

Nigel Henry cave.dnb at tiscali.fr
Thu Nov 10 13:54:50 EST 2005

On Saturday 05 November 2005 22:28, Erik de Castro Lopo wrote:
> Nigel Henry wrote:
> > Hi. Has anyone got sineshaper installed on FC3? I'm having the most
> > terrible dependency problems. gtkmm, then glibmm, and the list of deps
> > goes on and on. I thought that Fedora extras handled thes deps, but
> > adding the urls to yum for the fedora extras hasn't solved it. Yum says
> > gtkmm doesn't exist. I'm not knocking anything. I'd just like to get
> > sineshaper working, as it sounds like a good synth.
> I tried on debian testing. All I had to do was install libglademm-2.4-dev
> whcih pulld in some dependancies. Unfortunately debian doesn't have a
> package for DSSI so I stopped there.
> Erik
Hi Erik. I had to take a break from this, and have been messing with VSTi's, 
using Savihost under Wine, and that's going well. Back to Debian. This is on 
my Sarge install, using kernel 2.6.8-2-386. Installed libglademm-2.4-dev 
which picked up 18 dependencies and installed them all ok. Thanks to Lars 
Luthman I picked up all the DSSI stuff from http://willem.engen.nl/debian/ . 
Sineshaper works like a dream. It ain't got many knobs on it, but produces 
some really powerfull sounds. The one thing I found with it, is that after 
about 10 minutes lying idle it suddenly produces a sustained sound. Changing 
programs on the usb midi keyboard stops this. This is not a complaint. It was 
probably asking me to play with it more. Thanks for your help. Nigel.

More information about the Linux-audio-user mailing list