[linux-audio-user] Keyboard loss @ usb audio disconnect

Christoph Eckert ce at christeck.de
Tue Nov 15 15:00:45 EST 2005


> Not sure if I'm seeing the same problem, but it sounds like it might
> be. My midi controller (keystation) works fine for day after day of
> minimal use, and then one day I'll go to use it and it doesn't work.
> qjackctl sees it and can establish connections, dmesg reports nothing
> unusual. It just doesn't seem to be generating any events. I unplug
> its usb and it disappears from qjackctl. I plug it back in and it
> reappears, but still doesn't work. So I unplug the power and plug it
> back in, same thing. So I unload snd-usb-audio and unplug the usb and
> plug it back in and the same thing. Finally I give up and reboot.

did you try amidimon in a shell window (amidimon --ports all) or 
kmidimon to check if there realy is no MIDI coming in?

> Yesterday after rebooting, it still didn't work, so I unplugged all
> my USB devices (keyboard, mouse, scanner, keystation) and plugged the
> keystation back in, and then it worked.

Just to clearify: I loose my keyboard which is a notebook keyboard 
connected internally via psaux.

In your case, maybe it's a problem of coldplug vs. hotplug. I'd try to 
unplug the devices during boot time and plug it in after you logged in.

Furthermore, ensure that in your kernel config, drivers, usb you have 
*disabled* usb-midi and usb-audio. Both are OSS and conflict with the 
ALSA snd_usb_audio which handles four USB devices perfectly on my 
machine (except for the keyboard loss, of course :) .

Best regards


More information about the Linux-audio-user mailing list