[linux-audio-user] ALSA issues

Christoph Eckert ce at christeck.de
Wed Nov 16 18:23:28 EST 2005

Hi all,

I have some ALSA issues around for ages and I'd like to ask for help.

I'm running a Gentoo box and just updated to a vanilla with no 
further patches applied. I even updated ALSA to 1.0.10rc1. I'm using 
the kernel drivers, no external drivers installed. JACK was taken from 
CVS some time ago and is version 0.100.0, tmpdir /dev/shm installed.

I run an internal AC '97 chip (with modem functionality), a Terratec USB 
audio device, a Midisport 8x8, a m-audio Trigger Finger USB-MIDI device 
and (occasionally) an Edirol UM-1S. The firmware for the Midisport gets 
loaded via hotplug (very cool script BTW, thanks to the author) as well 
as snd_usb_audio gets loaded by hotplug.

Now the issues:

I.) According to http://alsa.opensrc.org/MultipleCards I tried to set 
the cards to a certain order because I'd (mainly) to see the Terratec 
card with the same number each time I log in. Unfortunately this 
doesn't work. I have included the content of the 
file /etc/modules.d/alsa at the end of this mail. The path to this file 
is Gentoo specific, but at least alsaconf uses it to enter it's 
entries. I wanted the internal AC '97 card to be the first one and the 
default for desktop use, but the ordering is as follows:

0 [Audio          ]: USB-Audio - USB Audio
USB Audio at usb-0000:00:1d.2-1.3, full speed

1 [Finger         ]: USB-Audio - USB Trigger Finger
M-Audio USB Trigger Finger at usb-0000:00:1d.2-1.4, full speed

2 [I82801CAICH3   ]: ICH - Intel 82801CA-ICH3
Intel 82801CA-ICH3 with CS4205 at 0xd800, irq 11

3 [Modem          ]: ICH-MODEM - Intel 82801CA-ICH3 Modem
Intel 82801CA-ICH3 Modem at 0xd400, irq 11

4 [M8x8           ]: USB-Audio - MidiSport 8x8
M-Audio MidiSport 8x8 at usb-0000:00:1d.2-1.1, full speed

Any hint would be really appreciated.

II.) When doing an /etc/init.d/alsasound restart, all cards are lost. 
cat /proc/asound/cards tell me "no cards". I get back my USB devices as 
soon as I replug them thanks to hotplug, but the internal card is lost 
until I reload the modules manually *or* reboot the machine. There 
seems to be some magic, or does the boot process additional things 
except invoking /etc/init.d/alsasound?!?

III.) Formerly I did loadthe snd_usb_audio module 
in /etc/conf.d/local.start so I could pass some parameters to improve 
USB audio latency:
modprobe snd-usb-audio nrpacks=1

What is the right place now as the module gets loaded via hotplug?

None of these problems is urgent, but I'd really like to know why my 
setup doesn't work as expected ("Computer, do what I want!" :) so any 
wee small hint would be great.

Thanks & best regards



# /etc/modules.d/alsa

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

options snd device_mode=0666

options snd cards_limit=7

alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# alias snd-card-1 snd-intel8x0m
alias snd-card-2 snd-usb-audio
alias snd-card-3 snd-usb-audio
alias snd-card-4 snd-usb-audio
alias snd-card-5 snd-usb-audio
alias snd-card-6 snd-virmidi

options snd-intel8x0 index=0
options snd-intel8x0m index=1
options snd-usb-audio index=2,3,4,5 vid=0x0ccd,0x0763,0x0763,0x0582   
options snd-virmidi index=6 midi_devs=2

More information about the Linux-audio-user mailing list