[linux-audio-user] Problems with Novation Speedio

Peter Clarke pgclarke at beeb.net
Sun Nov 20 03:17:17 EST 2005

Hi all,
I would like to use my Novation Speedio with Jack.  The 
Speedio is a USB audio/MIDI interface - sounds like it's 
similar to the Edirol UA-25 recently discussed here.

The MIDI side works fine, but I'm having problems with the 
audio.  The sound is terrible, both on playback and record.  
The music plays too slowly, at too low pitch, and with lots 
of crackles.  I've tried just about every combination of 
settings for Jack, but it hasn't helped.  I've tried 
Rosegarden and XMMS - the sound is just the same.  The 
Speedio hardware works fine with Win***s.  I also have a 
cheap CM8738-based soundcard, and that works just fine with 

My system is Gentoo 2.6.13 on a Pentium 4 PC.  I've just 
updated to Jack 0.100.0 (from the 0.99 currently 'approved' 
by Gentoo), but that didn't help.  Kernel support for OSS 
is turned off.  I have these modules loaded:  snd_seq_midi;  
sis900 (for my Ethernet card); realtime; snd_usb_audio; 
snd_usb_lib; ohci_hcd; snd_cmipci (for my CMI8738 
soundcard); snd_opl3_lib; snd_hwdep; snd_mpu401_uart; 
snd_rawmidi; ltserial, ltmodem (for my Winmodem).

I'm guessing it's an issue with the snd-usb-audio driver.  
Any ideas?  Could it be a conflict with aRts?  Does anyone 
have the Speedio working properly on a Linux box?

Peter Clarke

More information about the Linux-audio-user mailing list