[linux-audio-user] My CD Player/Burner stopped working

Mike Jewell mj405 at oneupaudio.com
Mon Sep 5 14:31:07 EDT 2005

Just to follow up on this in case someone else has this same problem
with xcdroast:

I believe that when I updated my os to Fedora Core 3, the version of
xcdroast (or maybe one of the apps it is a front-end for) changed so
that you need to be root to run it.  The bad part is that there is no
indication that this is the problem.  Here is the output when I DON'T
run it as root:

cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
   deleted lines...
Linux sg driver version: 3.5.27
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c
1.83 04/05/20 Copyright 1997 J. Schilling').
SCSI buffer size: 64512
   deleted lines...
cdrecord: Drive does not support TAO recording.
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
cdrecord: Illegal write mode for this drive.

When I run it as root, it seems to be (mostly) happy and writes a good
CD every time.

Mike Jewell
One-Up Audio

Mike Jewell wrote:

> >I have a Sony CD ROM in my Linux box.  It has worked fine from the
> >beginning but around the time I recently moved from Fedora Core 1 to
> >Core 3 (Planet CCRMA), it stopped working for burning (using xcdroast)
> >and playing through my Delta 1010LT sound card.  The timing could be a
> >coincidence but I suspect the setup got messed up somehow in the
> >transition.  If I put a audio CD in it, the sound comes out fine if I
> >plug my headphones into the built-in (to the player) headphone jack but
> >no sound comes through my sound card.
> >
> >My sound card is working fine for other apps like Audacity, Ardour,
> >aplay, etc.
> >
> >Can someone help me figure out what might have gone wrong?
> >
> >Thanks in advance for any tips.
> >
> >Mike

More information about the Linux-audio-user mailing list