[linux-audio-user] linuxsampler distortion?

Mark Knecht markknecht at gmail.com
Wed Apr 5 19:06:47 EDT 2006

On 4/5/06, Paul Winkler <pw_lists at slinkp.com> wrote:

> >
> > This sound similar to some problems people were having running emu10k1
> > devices at 44.1KHz, which disappeared when using 48KHz.
> See, this is why we have mailing lists :-)
> Problem solved.  I was using my sb128 PCI card, which uses
> snd_1371.  And I was indeed using it at 44100.  Alsa version 1.0.10.
> Switched sampling rate to 48000 (it took me a while to realize that
> field in the qsampler gui is editable! It doesn't look like it)...
> and problem is solved.
> Thanks Lee!!
> --
> Paul Winkler

Note that LinuxSamper does not resample the gig files to the 48K
sample rate so your samples are going to play about 1 note too high.
GigaStudio works the same way. Almost all gig files are recorded at
44.1K. Very few exceptions to that. (I have about 3000 gig files...)

If you want gig files in tune then you need to get a sound card that
works well at 44.1K or get the Alsa resampling stuff to work better.

CAVEAT: I haven't used LS in 6-8 months since they switched the
license to non-Open Source. Possibly they have added something that
addresses this, or attempts to, and was effecting the quality of the
audio you are getting.


More information about the Linux-audio-user mailing list