[linux-audio-user] Debian 2.6.14 alsa problems

tim hall tech at glastonburymusic.org.uk
Wed Jan 4 10:50:50 EST 2006

On Tuesday 03 January 2006 17:26, Lee Revell was like:
> On Tue, 2006-01-03 at 10:00 -0500, Laura Conrad wrote:
> > >>>>> "DB" == David Baron <d_baron at 012.net.il> writes:
> >
> >     DB> Still cannot get this to play. Kernel boots up fine loading of
> >     DB> any alsa fails with a bunch of undefined symbols. I am using
> >     DB> neither udev nor devfs (no longer in kernel)--based on an old
> >     DB> knoppix hdinstall, upgraded to Debian Sid.
> >
> >     DB> Kernels through 2.6.11 worked fine. 2.6.12 --mpu401 fails,
> >     DB> 2.6.14 alsa audio fails. Fun.
> >
> > That's very similar to my system, and I was pleasantly surprised that
> > installing 2.6.14 "just worked".  I had to run alsaconf, and then I
> > had audio with all the exact same problems I'd had with 2.6.12.  I
> > haven't had hardware MIDI working since 2.4 or maybe even 2.2, and I
> > haven't tested recording recently, but playing works fine.
> >
> > If you need to compare your setup to mine, feel free to ask.
> What soundcard driver are you using?  What exactly do you mean by
> "hardware midi doesn't work".
> Please, be specific with these bug reports or they are useless.

I have always found it necessary to add
to /etc/modules to get MIDI to work on my DeMuDi systems.

I find
to be a useful source of diagnostic info (you can always snip the modprobe 
conf section). I suspect most posters to this list aren't intending to make 
formal bug reports, however, if we make a habit of including this  
information in a familiar format it makes it easier for everyone to zero in 
on each particular case and may provide useful incidental information.

tim hall

More information about the Linux-audio-user mailing list