[linux-audio-user] Re: M-Audio MidiSport 2x2

Hans Fugal hans at fugal.net
Thu Jan 5 15:32:50 EST 2006

On Thu,  5 Jan 2006 at 19:57 +0800, Peter Clarke wrote:
> Markus Herhoffer <markus at herhoffer.net> wrote:
> > I've been using the M-Audio Midisport 2x2 together with
> > the Maya 44 USB for a long time and it worked quite well.
> > But after an update of ALSA only the Maya 44 works. The
> > module 'snd-usb-audio' is loaded properly and the device
> > is recognized by the system. I've also put
> > 'snd-usb-audio' on the blacklist of hotplug, because
> > hotplug makes some real trouble with USB audio devices.
> I had exactly the same problem when updating Gentoo 
> recently.  Hans Fugal kindly tried to help me on this list 
> on 6 Dec 2005, and sent me this informative link:
> http://sourceforge.net/tracker/index.php?func=detail&aid=1353514&group_id=87777&atid=584353
> However, that didn't fix it for me.  Now, I have an ugly 
> workaround in place:  a little script that gets run 
> by /etc/conf.d/local.start, which contains the following:
> #! /bin/bash
> modprobe snd-usb-audio
> cd /usr/share/usb/midisport
> fxload -D /proc/bus/usb/004/003 MidiSportLoader.ihx -I \ 
> MidiSport2x2.ihx
> exit
> This works, provided that the MidiSport is always at the 
> same USB bus address;  in your case, you will have to 
> change the /004/003 to /002/003.

And presuming you never unplug your keyboard... I can help you get it
working with udev if you'd like the more robust solution. What exactly
didn't work?

Hans Fugal ; http://hans.fugal.net
There's nothing remarkable about it. All one has to do is hit the 
right keys at the right time and the instrument plays itself.
    -- Johann Sebastian Bach
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.linuxaudio.org/pipermail/linux-audio-user/attachments/20060105/6578fb54/attachment.pgp 

More information about the Linux-audio-user mailing list