[linux-audio-user] virmidi and 2.6.14 (Demudi)

Dave Phillips dlphillips at woh.rr.com
Wed Jan 18 08:50:49 EST 2006

Clemens Ladisch wrote:

>>>You never mentioned the raw MIDI port (which es where the MIDI data
>>>shows up).
>>I'm not sure what you mean here.
>The raw MIDI ports are the old OSS device files (/dev/midi*).
>In your configuration, the virtual MIDI devices are configured like this:
>OSS emul.     ALSA raw MIDI      ALSA sequencer
>/dev/midi02   hw:2,0       <-->  80:0
>/dev/amidi02  hw:2,1       <-->  80:1
>              hw:2,2       <-->  80:2
>              hw:2,3       <-->  80:3
Thank you for that clarification. So the ALSA virtual MIDI ports are 
mapped to the raw MIDI ports ?

>Please run the following commands (in separate consoles):
>aseqdump -p 80:0
>amidi -p hw:2,0 -S "90 12 34 80 56 78"
>or, for the other direction:
>amidi -p hw:2,0 -d
>aplaymidi -p 80:0 something.mid
>Is there any output?
Yes, there is. But if I connect the virmidi port to a synth there's 
still no sound. The second example shows the MIDI file playing along 
fine, but using QJackCtl to connect 80:0 to a synth produces no sound. I 
set the port to the MIDI Thru port, got sound. How can this be happening ?

Btw, when I rebooted into Demudi this morning the virmidi card was 
placed first in my cards list in /proc/asound/cards. I removed the 
module and tried to reload it with index=2 but the load failed with an 
error stating that snd-virmidi.ko didn't exist. I tried loading it 
without the parameter, it loaded fine (but still doesn't work).

Also btw, I asked on the Demudi list whether anyone has this module 
actually working. One user reported that he has the same problem, i.e., 
the module loads but is not working. Same kernel (2.6.14).

And thank you very much for helping me with this trouble.



More information about the Linux-audio-user mailing list