[linux-audio-user] rosegarden-4-1.0: can't seem to get any MIDI out ...

Sylvain Robitaille lau at therockgarden.ca
Mon Jan 23 00:21:02 EST 2006

Hello ... (as an aside, please count me in as another Slackware-10.2
user, installing packages that don't ship with Slackware from source;
I've been off the list for a while, but just browsed the recent archives
and spotted that thread while looking for a solution to what follows ...)

After my partially crippled music workstation workstation finally stopped
booting altogether, I finally replaced it about a month ago (in fact,
the hardware itself was replaced just about exactly a month ago, though
I salvaged the audio interface from the previous system).

The system is an AMD Athlon64, with a Cirrus Logic CS 4624 sound card
("Hercules Fortissimo Game Surround"), and an onboard ATI SB400 AC'97
Audio Controller.  It seems that the ATI sound interface may be better
than the CS 4624 for some things, though it doesn't appear to have
any MIDI support, which the CS 4624 does, and which I consider quite
important for my purposes.  Drivers for both sound devices are compiled
into a custom monolithic kernel.  I haven't decided yet whether I'm
going to try using them together (for example to provide additional
outputs while processing sound files and mixing), or whether I'll use
one in favour of the other, but whichever I do, I'm going to need to to
use the CS46xx card for MIDI input and output.

I recently installed Rosegarden-4-1.0, after having last tried Rosegarden
in late 2003 (rosegarden-, and previously having successfully
used Rosegarden-2.1 to some extent.  Before I go on, I have to take a
moment to say thank you to the folks who worked on that (and frankly
on the couple dozen or so other audio applications I've installed that
are turning this system into a very respectable music workstation: from
Audacity and LinuxSampler, to Ardour and JAMin, and all the support
applications, gui frontends, and libraries that make them all tick).
You guys have (all!) done really great work.

Now the problem I'm having, I imagine is due more to my own lack of
understanding than to any failure in the software or (I hope) an error
in installation.

Most things I use seem to be working fine: I can control LinuxSampler (and
FLUIDSynth, with which I've also tested Rosegarden) from a MIDI keyboard
plugged into the computer's MIDI input (through a MIDI patchbay, but
it isn't configured to apply any sort of filtering on the MIDI stream).
I can play MIDI files with aplaymidi through a synthesizer plugged into
the computer's MIDI output (through the same MIDI patchbay).  However,
I can't seem to get any MIDI output from Rosegarden, either through
the softsynths (LinuxSampler or FLUIDsynth) or out the computer's MIDI
out port.

I've tried various configurations with JACK, but still no progress.
Can someone suggest where I should be looking for more information
about this?  I'll certainly provide more information if I've overlooked
anything important.

I've not tried Rosegarden's audio support (yet), though I was relieved to
find that it seems to import Rosegarden-2.x files apparently flawlessly.
Audio out works fine from other applications I've tried, though (Ardour,
Audacity, FluidSynth and LinuxSampler), so I'm not expecting to have
any problems with this function in Rosegarden.

Any help with my MIDI problem would be greatly appreciated ...

Sylvain Robitaille                              syl at alcor.concordia.ca

Major in Electroacoustic Studies                  Concordia University
Faculty of Fine Arts / Music Department       Montreal, Quebec, Canada

More information about the Linux-audio-user mailing list