[linux-audio-user] FC5 and Flash Audio

Thomas Ilnseher illth at gmx.de
Thu Jun 1 10:49:05 EDT 2006

Brad Fuller wrote:
> Bert Visser wrote:
>>> I've upgraded to FC5, and I'm slowly inching my way up to get audio
>>> working (PlanetCCRMA). I have a particular problem in that Flash video
>>> works fine, but I have no audio (occurs in Firefox, Opera and
>>> Konqueror.) I've searched for a solution and really haven't found
>>> anything that works. Some reports have said that a chmod to /dev/dsp of
>>> 0666 will help. Others say that changing the permissions on the
>>> "plugins" directory will do the trick. Nope, not for me.
>>> I noticed that I had no /dev/dsp. So, I kinda figured that maybe the
>>> Flash plugin hard defaults to writing to /dev/dsp. So I made one with
>>> ./MAKEDEV audio... and sure enough, a dsp1 was made. However, I still
>>> have no audio when playing flash in a browser.
/dev/dsp* are oss audio devices.

oss drivers are marked as depreciated in the kernel, and are replaced 
with alsa drivers.

thus i am sure, FC5 will use ALSA instead of oss.

there are oss compatibility modules for alsa, they are named:

do 'lsmod | grep oss' and see if these modules are loaded.
if yes, there is something foobared with your udev setup -
if no (thats what i expect) load these modules:

modprobe snd_pcm_oss
modprobe snd_mixer_oss
modprobe snd_seq_oss

note, for sound playback (flash), only the first module is required.

once you load the snd_pcm_oss module, udev should create /dev/dsp* as 
required automatically.

if sound playback still doesn't work, this might be because your 
soundcard has no built in mixing capabilities,
and some other application is using your audio device.
'other application' might include arts, which is started together with 
KDE check with 'ps aux  | grep artsd' and kill with 'killall artsd'.
the later command will disable sound in all kde apps.

if you are running KDE (and arts), you might also try running firefox as
'artsdsp firefox' from the konsole. this doesn't need the aforementioned 
kernel modules.

>>> Anyone come across this problem? Any ideas?
>>> brad
>> There is a special yum repo for macromedia. Try installing flash with
>> that as described on this page:
>> http://stanton-finley.net/fedora_core_5_installation_notes.html#
>> For me this did the trick.
> Thanks. Funny, I saw that after I sent the msg. But, it still doesn't
> work for me.
> bummer....

More information about the Linux-audio-user mailing list