[linux-audio-user] FC5 and Flash Audio

nigel henry cave.dnb at tiscali.fr
Thu Jun 1 15:56:16 EDT 2006

On Thursday 01 June 2006 16:27, Brad Fuller wrote:
> Bert Visser wrote:
> >> I've upgraded to FC5, and I'm slowly inching my way up to get audio
> >> working (PlanetCCRMA). I have a particular problem in that Flash video
> >> works fine, but I have no audio (occurs in Firefox, Opera and
> >> Konqueror.) I've searched for a solution and really haven't found
> >> anything that works. Some reports have said that a chmod to /dev/dsp of
> >> 0666 will help. Others say that changing the permissions on the
> >> "plugins" directory will do the trick. Nope, not for me.
> >>
> >> I noticed that I had no /dev/dsp. So, I kinda figured that maybe the
> >> Flash plugin hard defaults to writing to /dev/dsp. So I made one with
> >> ./MAKEDEV audio... and sure enough, a dsp1 was made. However, I still
> >> have no audio when playing flash in a browser.
> >>
> >> Anyone come across this problem? Any ideas?
> >>
> >> brad
> >
> > There is a special yum repo for macromedia. Try installing flash with
> > that as described on this page:
> >
> > http://stanton-finley.net/fedora_core_5_installation_notes.html#
> >
> > For me this did the trick.
> Thanks. Funny, I saw that after I sent the msg. But, it still doesn't
> work for me.
> bummer....

Hi. Sorry, I've lost the original post to this Flashplayer on FC5 problem.

I have no such problems with Flashplayer and Firefox.

Firefox version (from latest FC5 updates)
Kernel: 2.6.16-1.2080.13.rrt.rhfc5.ccrma  (from planetccrma)
Extra Alsa packages are all from planetccrma, including "alsa-oss" the alsa 
emulation layer for OSS.
Flash tried on http://laracameron.com/main.html  . Some of her stuff needs 
Flash, including sounds, and it works ok.

My Flashplayer install.

I have Apt installed, and added to /etc/apt/sources.list
rpm http://macromedia.mplug.org/ rpm macromedia

I could not find  a GPG key for it on their site, so after DL'ing the 
flash-plugin using Synaptic, you have to uncheck the verify signature box 
otherwise it won't install.

Then ran (as root) /usr/lib/flash-plugin/setup, and the Flashplayer just 
worked with Firefox, and no problems.

I can't say much more, as it just seems to work,


More information about the Linux-audio-user mailing list