[linux-audio-user] Recording ADAT inputs on RME hammerfall 9636/52

Stephen Cameron smcameron at yahoo.com
Tue Jun 20 20:57:51 EDT 2006

--- Mark Knecht <markknecht at gmail.com> wrote:
> > >    To set the card's clock rate will likely require use of some amixer
> > > commands. man amixer and then play around with reading out the
> > > controls in the driver. The correct solution here is to configure
> > > either your Hammerfall or the AW4416 as a clock slave. I don't have
> > > any problems using the ADAT lines to sync clocks so you could try that
> > > to begin with. It will certainly work well enough to test the
> > > connection. You can go to a spdif or Word Clock sync later if you need
> > > it. I'm not sure if you can do Word Clock sync on a DIGI9636 anyway.
> > > That connection may be on the DIGI9652 expander card. I cannot
> > > remember.
> >
> > Ok, this gives me some hints to play around with, and encouragement.
> > Thanks a bunch!  I imagine when I run, say qjackconnect,
> > I should expect to see a bunch of inputs and outputs to
> > the hammerfall?  But maybe my config files (asound... ) have
> > to be correct first?
> You should not need any config files. I don't use them. There is one
> file which is created by the system called /etc/asound.state which
> sometimes is outdated by Alsa updates. If that happens you'll get
> messages when Alsa starts (probably boot time for you - what distro?)
> and the messages will say things like a 'control' has incorrect
> values, etc. If that happens just erase asound.state and let the
> system create a new one.
> >
> > >    Anyway, it will work. Possibly you can post back your currect
> > > settings from /proc/asound/cards and the output of amixer's listing of
> > > controls and er can get you lined up pretty quickly.
> >
> > Ok, I will do that tonight.
> Will look in and see if I can help.
> Cheers,
> Mark

Well, here's what I've tried so far tonight:

Ran jack as root.
Ran qjackctl as root.

On the setup/Settings page:

Checked: Realime/hw monitor/hw meter.
Left other messages alone.

Priority: 0
Prames/period: 1024 (a guess)
sample rate:22050 (default...)
Periods/Buffer: 2
Port Max: 128
Timeout: 500ms
Interface: hw:1
Dither: none
Input device:(default)
output device:(default)
input channels: 0
output channels: 0
input latency: 0
output latency: 0
Latency: 92.9 msec

The "input channels: 0" and "output channels: 0"
seem suspicious.  If I try to change them Jack 
won't start and says: "ALSA: cannot set channel 
count to 1 for capture"  If I leave them zero, jack
will start (but I don't know if that's right.)

On the AW4416:

On the Setup/Patch In page, it looks like
SL2-1 through SL2-8 are mapped to mixer input channels
17-24.  For the mixer 1-24/rtn-1-2, I pushed the faders
up.  On the "Home" screen, 1-24/rtn, I can monitor the

I ran ecasound like so:

ecasound -c -b:1024 -i:planet-zoing-zoing-banjomix.wav -o:jack

Then "start"

Then in qjackctl, I can see ecasound in the "capture" column,
and I routed it to every single output (all 18 of them --
presumably 2 s/pdif outs + 16 ADAT outs.)  So I am seeing
the hammerfall having 18 ports, which is encouraging

I got nothing on the AW4416 where I would expect the sound
from the wav file to show up on all 8 ADAT inputs.

That's where things stand right now.

-- steve

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the Linux-audio-user mailing list