[linux-audio-user] RT and Jack problems

Mark Knecht markknecht at gmail.com
Wed Jun 21 17:34:13 EDT 2006

On 6/21/06, Hiram Abiff <domain.admin at online.ie> wrote:
> Quoting Mark Knecht <markknecht at gmail.com>:
> > Hiram,
> >   There are a few things to discover:
> >
> > 1) Are you running Jack as root or a user?
> >
> > - First, try running Jack as root and see if these problems go away.
> >
> Gruß Dich, Mark
> I tried running it as root, works great.
> I recompiled my kernel with the required module, I created a realtime
> group, added my user to it and loaded the module. lsmod reports
> it's loaded. However, I still get the same error messages when running
> muse. :(

It may be the way you are loading the realtime module. Here's how I do
it at boot time on my Gentoo box in /etc/modules.autoload/kernel-2.6:

realtime gid=600 any=1

and here is how I set up my group:

mark at lightning ~ $ cat /etc/group | grep realtime
mark at lightning ~ $

Nothing more than that and I work fine.

lightning ~ # modinfo realtime
filename:       /lib/modules/2.6.17-rt1/extra/realtime.ko
license:        GPL
description:    Realtime Capabilities Security Module
vermagic:       2.6.17-rt1 preempt mod_unload gcc-3.4
license:        GPL
description:    Standard Linux Common Capabilities Security Module
vermagic:       2.6.17-rt1 preempt mod_unload gcc-3.4
parm:           any: grant realtime privileges to any process. (int)
parm:           gid: the group ID with access to realtime privileges. (int)
parm:           mlock: enable memory locking privileges. (int)
lightning ~ #

Hope this helps,

And here is houw I

More information about the Linux-audio-user mailing list