[linux-audio-user] kernel 2.6.17-rt4 and usb

Gian Paolo Mureddu gmureddu at prodigy.net.mx
Thu Jun 29 04:26:17 EDT 2006

Hash: SHA1

Atte André Jensen escribió:
> Hi
> I just rolled my own 2.6.17-rt4 (I'm now running 2.6.15) and upon
> boot it seems that usb was "not working". My usb mouse sisn't work,
> neither did my usb soundcard or my usb midi keyboard.
> I seem to remember something about udev, but before I start messing
> with my system, I'd appreciate if someone could confirm that this
> this coould in fact be the cause of the problem.
> If so; how reversible is the process of installing udev, I seem to
> remember something going... not so well some time back when last
> tried to go back from udev.
> If not; what else could be the problem? Surely someone else must
> have had this problem...
> I'm running debian/stable and I simply took my trusty 2.6.15 config
> and copied it to /use/src/linux (symlinked to actual kernel tree)
> and ran gconfig + save before making the kernel.
> Thanks in advance for any advice.
I have not run into these problems with the -rt series yet... Though I
had other issues. I'd recommend doing a full
oldconfig/menconfig/xconfig configuration of the kernel (using your
2.6.15 config as template), as some times I've run into some problems
where configurations don't "scale" up all that well, and I end up
doing a whole kernel anyway... Oddly enough this has been the case for
odd numbers rather than pair ones (go figure), however I'm using
Fedora and I can't say about Debian's udev version. I have had no
problems with Fedora's udev and many -rt kernels I've tried (plus the
PAM "hack" for pam >= 0.99.x)
Version: GnuPG v1.4.3 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the Linux-audio-user mailing list