[linux-audio-user] Re: [Alsa-user] VxPocket and hotplug - need help getting it working

Asbjørn Sæbø asbjs at stud.ntnu.no
Tue Mar 14 09:52:33 EST 2006

(I am cc-ing the linux audio user list, in the hope of broadening 
the audience and reaching someone able to help me sort this out.)

On Tue, Mar 14, 2006 at 12:02:56PM +0100, Asbjørn Sæbø wrote:
> I am trying to get a Digigram VxPocket sound card working, and really
> need some advice on how to proceed.
> [Rest of previous post far below.]

In addition to what I have done before (see below), I have now created a 
/etc/pcmcia/vxpocket.conf according to the description at the bottom of 
the alsa-project page for the vxpocket card.  And I have added the 
necessary lines to /etc/modutils/alsa-base, and run update-modules.

The visible results of this is that
* The vx-* modules now seem to be loaded at boot
* The card is still not recognized by alsa (it is not listed in 
  /proc/asound/cards, and alsaconf does not find it).
* cardinfo no longer says "unsupported card", but "empty".  It does 
  however list "IO 0x100-0x10f" and "IRQ 5" (or "IRQ 9d" or "IRQ o"(?)).
* "cardctl info" and "cardctl ident" hang when they come to the socket 
  containing the card.
* Restarting the pcmcia service gives the following error messages:

snegle:~# invoke-rc.d pcmcia restart
Shutting down PCMCIA services: /etc/init.d/pcmcia: line 173: kill: (4040) - No such process
Starting PCMCIA services: cardmgr[4540]: watching 2 sockets
cardmgr[4540]: could not adjust resource: IO ports 0x100-0x4ff: Device or resource busy
cardmgr[4540]: could not adjust resource: IO ports 0x800-0x8ff: Device or resource busy
cardmgr[4540]: could not adjust resource: IO ports 0xc00-0xcff: Device or resource busy
cardmgr[4540]: could not adjust resource: memory 0xc0000-0xfffff: Input/output error
cardmgr[4540]: could not adjust resource: memory 0xa0000000-0xa0ffffff: Input/output error
cardmgr[4540]: could not adjust resource: memory 0x60000000-0x60ffffff: Input/output error
cardmgr[4540]: could not adjust resource: IO ports 0xa00-0xaff: Device or resource busy

I am beginning to suspect that I am up against some pcmcia bug.  And I 
am, at least for now, out of ideas of what to try next to get this card 
working.  Suggestions, advice and tips are very welcome!



> The system is an ASUS L5000-series laptop running DeMuDi 1.2.1.  The
> kernel is 2.6.12-3-multimedia. 
> So far, I have installed the pcmcia-cs package and the hotplug package.  
> (Do I need both of these?  Do they conflict in any way?)
> From what I have read of documentation, it seems that with 2.6-kernels, 
> hotplug is the way to go.  Does having the "cardmgr" running interfere 
> with this?
> I have also downloaded the alsa-firmware corresponding to the alsa 
> version installed (1.0.9).  (DeMuDi does not distribute this firmware.)  
> I ran "./configure --disable-loader", "make" and "make install".  
> This resulted in a set of files being placed under
> /usr/lib/hotplug/firmware, among them, it seems, files related to the
> vxpocket cards.
> The PCCard system itself seems to be working.  At boot, a Yenta card bus 
> bridge is found.  And "cardinfo" seems to notice that the card is 
> present, but only says "unsupported card".  
> "alsaconf" does not find the card. Trying to load the snd-vxpocket
> module gives no errors, and the module seems to be loaded afterwards
> (see below), but the card is still not found by "alsaconf".
> I have tried to run "vxloader" (is that depreceated?), which gives the 
> message "no VX-compatible cards found".
> Where do I go from here?  How do I get the card to be recognized?   And 
> what do I do to get the firmware uploaded to the card?
> With kind regards
> Asbjørn Sæbø
> snegle:~# lsmod |grep vx
> snegle:~# modprobe snd-vxpocket
> Restoring ALSA mixer settings ... done.
> snegle:~# lsmod |grep vx
> snd_vxpocket            4288  0 
> snd_vx_cs              14080  1 snd_vxpocket
> snd_vx_lib             36480  1 snd_vx_cs
> firmware_class         10624  1 snd_vx_lib
> pcmcia                 28480  10 snd_vxpocket,snd_vx_cs
> pcmcia_core            52628  4 
> snd_vx_cs,pcmcia,yenta_socket,rsrc_nonstatic
> snd_pcm                96580  4 
> snd_vx_lib,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
> snd                    58404  12 
> snd_vx_cs,snd_vx_lib,snd_seq_oss,snd_rawmidi,snd_seq,snd_seq_device,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
> snegle:~# 

More information about the Linux-audio-user mailing list