[LAU] Re: Pops and clicks but no xruns - SOLVED

Spencer Russell spencer.f.russell at gmail.com
Thu Apr 5 02:22:06 EDT 2007

Ah hah! Turns out my card only likes 3 periods, not 2. Thanks LAU archives!


On 4/5/07, Spencer Russell <spencer.f.russell at gmail.com> wrote:
> Recently I posted regarding nice low latencies on my brand-spankin-new
> Thinkpad R60. I was a bit premature though, because when I actually
> run any sound through jack I'm still getting lots of pops and clicks
> in my audio. I am not, however, getting any Xruns. I'm not sure what
> to look for as a culprit.
> I already enabled "force 16 bit", which got rid of some nasty
> distortion, maybe something wacky with my IRQs? One of my worries is
> that the HDA card is on the same interrupt as my firewire and one of
> my USB drives. When I remove the modules though, leaving only HDA on
> its own interrupt, i still get the pops.
> When I use audio without jack I get no clicks or pops, and changing
> jackd to capture only doesn't seem to help. I also boosted the
> priority of that interrupt thread with chrt --fifo --pid 99 `pidof
> 'IRQ 4'` without any change.
> What could cause clicks without xruns? I'm baffled.
> -spencer

More information about the Linux-audio-user mailing list